Ignore Macro when typing in Sketch

Hey everyone!

I just discovered Keyboard Maestro and it's been a massive lifesaver. I'm currently using it to remap Sketch's default controls to other keys. Specifically tools to single key hot keys (Rectangle to M, etc). However i've run into one thing i cannot figure out how to do. Whenever i type text in a field or when i'm type setting i'm interrupted by my single key macros. Is there a way to set exceptions when typing text or into a field or something?

Thank you for your help!

Hey Drew,

Unfortunately not. There's no low level method for Keyboard Maestro to detect when you've entered a text field and thus change its behavior.

The best you can do is set your single-key macros up as a palette that can be toggled on/off.

I do this in several apps, and I want the palette visible to give remind me that things are different.

E.g. I want that strong visual cue that 1-key shortcuts are active.

Here's an example:

Hotkeys/macros only activated on one specified (certain) url


Thanks for the quick reply Chris!

That's so sad to hear :frowning: For now i'm just making a Macro to disable all of my hotkeys so i can type, than reenable it. Hopefully we'll see something like that come in the future :slight_smile: Thanks for the help