Insert Text by Pasting not working. Pasting twice

I create this macro

CleanShot 2023-01-19 at 21.57.16

but when I type 'thx', the result like ThaThanks

Restart Mac is not working. What should I do to fix?

macOS (13.1) and Keyboard Maestro (Version 10.2)
Thanks.kmmacros (1.4 KB)

Solved! After I delete snippets on other app, it works Thanks for help!

Try using 'Insert Text by Typing' and see if your result is better.

Hey @Yohan,

Please post an actual, testable macro.

Where is the problem occurring? Everywhere? Or just in certain contexts?

  • What version of macOS are you using?
  • What version of Keyboard Maestro are you using?

This problem is not completely unheard of but is not at all normal.


I also add other languages on the keyboard, but if you set it as a typing,
if the language other than English is activated, the text is typed in a
other language than English, so I cannot set it up as a typing. Thanks for reply!

How can I post a testable macro? I already upload a screenshot of the full macro.

It happens everywhere and in all apps. Most other text macros I made with same rule have issues (not just ThaThanks)

I use the latest macOS (13.1) and Keyboard Maestro (Version 10.2)

Here is the gif. Just duplicate macro with KeyboardMaestroTest text. it works but still not thx (ThaThanks)

CleanShot 2023-01-20 at 06.11.48

So, you're asking people to take their valuable time reconstructing a macro you've already built just to help you?


If you haven't read this it's worth a couple of minutes of your time.

Take Care,

(Keyboard Maestro Moderator)

No I'm just asking It's my first to use this forum Sorry about it

I will use automatic sharing next time. For this time, I attached the macro file.
Thanks for your help!

1 Like


This kind of problem as I mentioned is uncommon and can be hard to diagnose.

  • Do you have a system text expansion for 'thx" or "th"?
  • What happens if you change the trigger abbreviation text to something other than "thx"?
  • Could you have another utility on your system that's interfering with the macro?

One of your questions reminds me I set snippet on other app with the same hotkeys. After I delete all snippets on Alfred It works well! Thanks a lot for your help! :+1:


The only way I can see that happening is if you have a system shortcut that also maps “thk” to Thanks.

After typing “thx”, Keyboard Maestro will simulate the following events:

  • Type a Backspace
  • Type a Backspace
  • Type a Backspace
  • Set clipboard to “Thanks”
  • Type Command-V

thus there is absolutely no way to get "ThaThanks" unless something else is involved.


Ah I see now I understand how Keyboard Maestro works more. Thanks!

1 Like

Instead of thx change it to tzz and see if problem is fixed first.

1 Like