Is it possible to create and action which would trigger a Chrome extension (Evernote Web Clipper)?

thanks very much for your time and help

Any reason you can't use the Evernote clipper's built-in shortcuts, either in a macro or otherwise?

1 Like

everything I needed and much more.
Thanks to you, I will save a lot of time in the future
thank you very much

1 Like

Heh, you’re quite welcome. If only all problems were solved so easily :slightly_smiling_face:

1 Like

I would like to call up EV web clipper, and then end up in the title field which I will edit. I can’t find a shortcut and using the tab key does not work. Would you know if there could be any alternative to a trackpad tap?

On my system, I’m able to tab to the title field by first hitting Tab, then hitting Shift-Tab twice. Does that work for you too?

1 Like

yes it works fine. God knows how you figured that out !
thanks very much

1 Like

Hi, funny thing, I encountered 2 problems.
EWC = Evernote Web Clipper Browser = Chrome
1- I can activate the EWC by clicking on the elephant icon in the toolbar. Never any problem.
2- I can activate the EWC by typing the hotkey defined within the EWC in Chrome (as per your instructions), but after a few times, i get a pop up message, as per snapshots below. I tried different web sites and I get popups irrespective of the web site. Although I get a pop up message, the EWC still works. The only irritant is that I have to click on OK each time. As I mentioned, this happens after a few uses, not the first times, so it's unpredictable.
3- even stranger, I am unable to create a KBM macro shortcut which would in turn activate the EWC by typing the EWC shortcut. I tried different keystroke combinations and could not make it work. To see if the problem stems from KBM or Chrome (for whatever reason), I created a BTT gesture to trigger the EWC shortcut, and ended up with exactly the same problem as with KBM. Is there any reason it would be a Chrome issue? How could Chrome 'see' where the keyboard shortcut comes from: the EWC itself, KBM or BTT?
thanks very much for your help

I have no idea why Chrome doesn't register the macro/BTT-based keystroke to activate the EWC immediately, but I was able to figure out a workaround: just add a delay at the start of the macro. In my tests, 0.2 seconds was sufficient to make macro-based EWC activation work, while 0.1 seconds failed consistently. You might need to adjust the delay for your system, but whatever is going on with Chrome failing to see simulated keystrokes, this seems like it should be all you need to add to get around it.

As for the OK button appearing randomly, there's a macro-based way to handle that too. Here's a full macro that includes both the delay I just described and the OK button workaround:

The key thing about the OK button workaround is that the timeout settings for the Pause Until action have been changed from the defaults to this:

This stops the macro gracefully without presenting the user with an error message if it doesn't find an OK button, and if it does find one, it clicks it right away so you don't have to.

EDIT: I remembered you wanted the EWC to select the title field automatically upon being activated, and adding that to the macro so that it worked consistently proved tricky enough that I thought I'd update the macro I posted earlier and show you how I did it:

Trigger EWC.kmmacros (27.3 KB)

The keys to this version are that the Press Button action's timeout has also been changed to no longer abort the macro if the button isn't found (in the earlier version, that wasn't necessary since it was the final action), the inclusion of a Pause Until Found Image condition for the EWC save button (I generally try not to rely on found images, but in the EWC's case this seemed like the most expedient way, especially given the button's unique design that makes it well-suited for a found image), and the Set Actions Delay that gives the Tab/Shift-Tab keystrokes enough time for the slow EWC to register them. Please note again that you may need to adjust the delays used here so that the macro works consistently on your system.

1 Like

I greatly appreciate all the time you have put into this.
unfortunately, the macro does not work:

  • i tested incremental delays up to 5 seconds
  • I tested multiple keyboard shortcut combinations
    Thanks very much for everything. I feel bad that you have spent so much time on this issue.
    We can leave it at that and accept that there is a problem with KBM and Chrome in some circumstances.
1 Like

Here is my version of how to do this. It is similar to that of @gglick, but I handle the issue with the "OK" button that sometimes appears differently.

MACRO: Trigger Evernote Web Clipper [Example]

If you have questions/issues with the macro, please post in the above thread.