Issue with menu trigger

This happens quite often and I have no idea what causes it...
I have this menu that I want to trigger. The program is already open and running, so there's no issues of it still being open and all that. Look at how the menu is there:

This is my action:

And yet, it takes me 2-3 tries to make it work. I get a notification that the macro couldn't process that action. Once I make it run successfully, it runs every time.

Any idea what may cause this and how to fix it? I love KM, but sometimes this kind of behavior that makes no sense makes me feel as if I can't fully trust the program with certain tasks that could lead to issues if I'm not around. A few days ago I was working on hundreds of files and using a certain macro that after 10 files or so would just stop working. Then back again. Nothing changed. KM just decided to stop running the macro.

Any tip on how to make KM as reliable as possible? Sometimes I increase the macro delay to make it a bit more stable, but it's not always the solution. Even with the delay, pauses, etc, sometimes it just doesn't run without issues...

Any help is appreciated! :slight_smile:

What if you "Try" just that action or create a new macro with only that action in it? Is it reliable then?

I just tried it and it makes no difference...
One thing I noticed: when I open the project, if I click File (before running the macro) and then click somewhere else to close that menu, if I then run the macro it runs. It seems that it unlocks, as weird as it may sound.

So once I open the project, if I try it, nothing happens (for some reason now it's showing the notification way after the whole thing is done... go figure...).
Once I click File, it seems to "unlock" and then it runs... makes no sense.
Kapture 2022-08-09 at 22.13.34

Update: I decided to try with BetterTouchTool and I'm getting the same result...
I tried with another app, choosing a menu action and it works. Why is Logic behaving like that? I don't get it...
Any suggestion besides creating a Click Found Image to click the File first to "unlock"?

Such a weird behavior... this is a Logic issue. When I open the project and I try to add the action, look at how the menu doesn't show the Edit Alternatives option:

If I then go back to Logic and click File, then go back to KM, now I see that option:

The same is happening with the menu above that one (Revert to). So weird...
I guess I will have to rely on Click at Found Image to unlock it and then run the action.
Oh well :wink:

FIX: I just added this as my first action (which is a double click at FILE to unlock it) and it seems to be working as expected:

NOTE: the issue I was having was clearly a KM issue, regardless, because it was working for like 10 times and then it would stop. Before you think this is all my fault haha

I don't think it's your fault -- but I don't think it's a KM issue either.

There's (at least) two ways to present menus -- everything is always there but item selection is enabled/disabled by context, or menus are populated by context. It would appear that this particular sub-menu is generated by the second method, and stuff isn't there until you go and look for it.

That would make it difficult for KM -- or anything -- to select a sub-menu item unless you can find some way to force the issue. It looks like you have, and hopefully it'll carry on working for you. You could also try selecting the "Project Alternatives" item and seeing if that makes the sub-menu items available to the next action.

One of those application idiosyncrasies you'll just have to be aware of and work around. Logic seems to have a fair few of those!


Yep. I’ve found this to be true with Logic.

I would do it like this:

Edit Alternatives.kmmacros (47 KB)

Macro screenshot


As an aside, I've noticed that KM changes Logic Pro to Logic Pro X, but only for the first line, whenever I use AS for UI interaction and the script is compiled. Odd.

Also, there's this, if you don't mind setting a new hotkey.


1 Like

That's a good one too. And no, I don't mind that, because in this case, it's a temporary macro. I'm going over all my projects and removing the name of the alternative, because I don't use alternatives and the name at the top can become pretty confusing, especially when you rename the project's name, now you end up with 2 names.

Regarding the macro you shared, wouldn't then just be easier/cleaner to use the applescript without the IF action?

No idea what you mean, but cool.

That's entirely up to you. It's slightly neater looking in practice not to have the menu pop up visibly, so I figured this way it would work that way at least some of the time. There's no downside to doing it this way, but of course the neatest of all methods is to use the native Logic key command.

For example if your project is called “My Song” the first alternative is called “My Song” as well. Now if you rename the project to “Sunset”, at the top of the window (the window’s title) will be something like “Sunset - My Song - Tracks”. Now this is a short name, but longer names become kinda messy. And since I don’t use alternatives at all, having that extra title makes no sense. So I go to alternatives and just rename the alternative to an empty name. So the title will just have the project name and gets updated when I rename it. Hope it makes sense

Not to be pedantic, but that's only the case when you've manually created an alternative. If you rename a project without new alternatives, it just changes the name.

I've never given much thought to it, as it has no importance to me beyond the window title. We all have our bugbears though. One of mine is the new white project icon that looks indistinct from text/AAC files in list/column view. I tend to change these back to the black/grey one. I haven't yet found a way to change them system-wide.

Have you had a dig through the app package -- maybe Contents->Resources -- to see if you can find and edit the disliked icon?

I'm sure I don't have to tell you to work on a copy of the app first!


That reads like a "display in the Finder" problem -- I thought you meant an icon within Logic's GUI.

1 Like

When you create a new project it creates a new alternative. Try it. If the project is new and since the alternative has the same name, you won't see it in the title, but once you change the project's name, you will see both. David in the forum does the same thing (deleting the alternative's name, for the exact same reason).

Maybe that's on a different version. Mine is 10.6.3 so maybe that's why.


CleanShot 2022-08-10 at 23.04.54|690x413, 100%, 70%

I'm on 10.7.4, so yeah probably. Maybe they changed the alternatives name thing too...?

Weird… David from Logic Pro Help said he does the same and I would assume he’s also on the latest version?

So when you create a new project and save it and then go to the alternatives list what do you see? Can you share a screenshot?