Just installed Ventura and now certain Press Button When Enabled actions have stopped working

Hi, as the title states, I've just installed Ventura and now find that some Press Button When Enabled actions have stopped working. The following gets triggered when I launch Logic Pro, to turn off my cloud backups til I quit Logic. It worked til Ventura; now it doesn't seem to recognize the Settings… button anymore.

I used the Interactive Help; it confirmed that my permissions are OK.

I also, for completeness' sake, attempted to toggle off and back on the app and engine permissions under System Settings > Privacy... > Accessibility - but weirdly, the on/off switches snap right back to On position rather than allowing me to turn off, then turn back on. So I removed items from the list and re-added them. No change.

I searched here but didn't see this specific problem mentioned.

UPDATE: see Peter's response.
And some good news: The following example, which presses the standard Save button, works perfectly, which indicates that it's only 3rd-party buttons we can't count on under Ventura:

I believe in Ventura, Apple changed a lot of buttons to use AXAttributedDescription instead of AXDescription, which will mean that the button cannot be found looking for the AXDescription.

The next version of Keyboard Maestro will look for both.


You’re a prince for responding so quickly. Thank you!

Is there any particular reason why you don't just use image recognition?

A quick google pointed me to macos - Easier way to make BackBlaze pause/resume updating - Super User

Basically you can use a couple of shell commands to pause and restart BB. Respectively:

/Library/Backblaze.bzpkg/bztransmit -pausebackup
/Library/Backblaze.bzpkg/bztransmit -completesync

I haven’t tried these so YMMV but if they work they’re a much cleaner method!

1 Like

A couple, yep. Because

  • to my mind, "Press a button called x" seems a heck of a lot more robust than "look for this image" (but I do use Click at Found Image a lot and am really grateful it exists)
  • the Press a button action has been working perfectly for a long while, until yesterday.

My question genuinely was "why did this stop working" rather than, "what other approaches could I try," but I appreciate you taking time to suggest some!


Of course :grinning: I should have written ... image recognition ... until the next KM update.

I always think automatically further, because usually a pure analysis of the problem gives me less than a new solution.

By the way, an Apple script that you can trigger with KM should also work. I don't know, but I've heard the Automator or Scripteditor can automatically create a script with "Record".

Thanks, tiffle! I remember Michael Hyatt posting here about this very thing.

So, here's my schtick: I've got an online class about Keyboard Maestro that targets creative pros who might normally not even attempt automation, on the assumption that it's too complex. So whenever possible, I build my own macros without scripting. I'm trying to keep it as accessible as possible.

The hilarious thing is that the second class in the series, which I just finished scripting, covers the various Pause/Wait options – including a bit about Press a Button When Enabled and using this very macro as the demo. Yikes!

But hey – now I have a great opportunity to cover the many other possible approaches. :smile:

There's always a silver lining!

1 Like

It's true! Now that UI Browser doesn't seem to be getting updated anymore (and I didn't buy it before), Record is what I use to get bits of script quickly when I need to.

Thanks for mentioning that. For anyone else reading this here is a link to @michaelhyatt’s post

1 Like