Keyboard Maestro Can't Type Shift-CMD-F16?

I'm stumped. When I include the "type keystroke" step in my Macro, my mac just beeps at me when it gets to that step. But if I stop the macro there, and manually type the keystroke, it works as expected.

Shift-CMD-F16 is supposed to be received by the app Mosaic and it's supposed to send the current window to a certain position. I know I could work around this by using KM's window manipulation tools, but I'd love to know what I'm doing wrong here...

Hey @mattf

Try changing the keyboard shortcut around to something simple like J.

If you're still having problems then it's likely that Mosaic isn't seeing the keystroke when Keyboard Maestro drops it into the event queue. We see this kind of problem sometimes when simulating keystrokes.

@peternlewis will no doubt drop in eventually and give a more technically complete answer.  :sunglasses:


It could be an accessibility issue, see: Accessibility Permission Problem assistance.

Does typing other keystrokes work?

Yes, other keystrokes work fine. The same macro successfully does CMD-W and OPT-CMD-N. But those aren't directed at Mosaic. The Shift-CMD-F16 is a keystroke that gets types when Omnifocus is active, but Mosaic normally "intercepts" it and performs an action on the current window, which is an Omnifocus window. The keystroke works fine if I type it manually, but not if KM sends it.

I tried deleting the accessibility permissions for KM and having the system restore them, but that didn't help either.

OK, then it is not an accessibility issue.

Seems like it is probably this issue:

Catalina doesn't support triggering hot keys with simulated keys for function keys or arrow keys, but weirdly does allow it for other keys. Whether this is a bug or a “feature” is unknown. If you can change the target hot key to something other than an arrow or function key, then Keyboard Maestro can trigger it based on simulating the key.

Correction. Yes, I can change it. That indeed worked. Thanks!