Keyboard Maestro Editor Opens When I Trigger a Macro

Here is niggle that happens everytime I trigger a macro. The macros runs and main application opens. If I close the application and trigger a macro, the main application opens. This only happens on one Mac that I run Keyboard Maestro on.

Scratches head. Any ideas on how to stop this happening?

Hi there, generally speaking, and macro that interacts with an app requires it to be open and depending on the actions you have in the macro, they might be activating that app.

But a little more context is needed to be able to help out. If possible, you can export and upload your macro here (simply select export macro from the File menu in Keyboard Maestro, then drag and drop that file into the browser here). Screenshots also help.

1 Like

Hey Frederick,

Verbal descriptions of problems tend to leave out critical information.

Please post your macro – or a macro with the minimum number of steps necessary to demonstrate your problem.

If we're not testing we're probably guessing, and guessing frequently wastes a lot of folks' precious time.

How to Post Your Macro to the Forum

If you haven't read this it's worth a couple of minutes of your time.

Tip: How Do I Get The Best Answer in the Shortest Time?

Take Care,

(Keyboard Maestro Moderator)

Thanks, sorry I wasn’t clear. When I wrote “every time I run a macro” I should have wrote “everytime I run any macro . . .” I haven’t noticed any macro that doesn’t trigger the activation of the KM application on Mac A.

I use the same macros on Mac B, (shared library in Dropbox) and all is well, the KM app does not actvitate, unless I launch it.

Hey Frederick,

It wasn't clear before that you were talking about the Keyboard Maestro Editor.


  • Download a new copy.
  • Delete the old one.
  • Manually drag the new one to /Applications or wherever you've put it.

If it still has problems run the Interactive Help in the Keyboard Maestro Editor's Help menu.


Thanks! That seems to have solved the problem! Thanks! Thought the issue was caused by a corrupted setting. Didn't think of a complete reinstall.


My best guess is that the Keyboard was translocated, but it could have been something else.

assistance:Translocation Problem [Keyboard Maestro Wiki]