Keyboard Maestro editor unintentionally inserting modifiers in to search field

I am using the latest version of KM in Monterey, and for some months it has been displaying some behaviour that I find rather annoying. I use the shortcut Control + Shift + K to switch to KM, and when I do so, the character ⌃ is automatically typed in the Search bar and a search is initiated in the folder that happens to be selected at the time, which results in most of the macros in that folder disappearing from view. Likewise, if I use a shortcut in the Editor, one of the modifier keys is automatically typed in the Search bar and a search is initiated, with a similar result. Is there any way to prevent this behaviour?

I would like to help, but I can't help without seeing your macro. Some people may also want to know the version number of macOS and the version number of KM that you are using.

Using KM macros on the KM editor itself is problematic, because the KM Editor can interfere with itself while your macro is running, sometimes as a direct effect of your macro. So it can be tricky. I haven't dared to try that yet.

I'm using KM version 11.0.2 and macOS 12.7, and the macros I was using when this behaviour occurred in the editor were just keyboard shortcuts assigned to menu items. But now the problem has miraculously gone away :person_shrugging:. I'm wondering what I could have done to cause it in the first place and now to make it suddenly go away. I'll report back if it recurs.

This is due to a feature that rolled out with KM10, in that when the cursor is in the KM Editor search field, tapping a modifier key inputs that key character.

I brought this up shortly after v10 rolled out a couple of years ago (see my linked post below), asking if there was a way to disable it, to which @peternlewis replied that there wasn’t, but if it was sufficiently annoying to enough people he would perhaps change the behavior (or something to that effect). I haven’t really seen many people bring it up in the two years since, and I myself have simply gotten used to it, so I doubt the behavior will be changed in the future.

2 Likes

Try changing the hot key activation from the default is pressed to is released. Does that help?

I haven't accidentally entered modifier symbols into the search field for quite some time now – but that's probably due to having refined timings in the QMK settings in my keyboard. (When your control key is also an S, your experience may not be typical. :laughing:)

1 Like

It's good to know that I wasn't imagining it! I suppose the issue (for me) is that the cursor is sometimes being automatically placed in the Search Field when, for example, switching to KM, which then brings about this behaviour.

I would very much like a way to disable this, @peternlewis. Probably 50% of the time when I am trying to enter search criteria, modifiers get added to whatever I'm trying to type!

I am unlikely to disable the feature.

If the specific issue of it putting in the modifier happens when you use a hot key like Control-Shift-K and you happen already to be in the search field, then that is an issue I can look at resolving.

If there are other specific ways in which a modifier gets added unintentionally, then feel free to report them.

I love the power of the Keyboard Maestro Search, but like others have experienced some challenges when attempting to type in my criteria in the Search field. That was part of my motivation to create a macro name Search All Macros. It can be found near the top of this thread:

Keyboard Maestro Editor Megathread