Keyboard navigation in a macro palette

I think the answer will be very obvious... But I can't find it.

I have a hotkey that launches a palette with a Macro Group containing several iTunes playlists. If I then click one of the playlists, that playlist starts to play immediately in iTunes.

Obviously I'd like to use a keyboard shortcut to select one of these entries, but I can't seem to create a shortcut that only fires when this palette is showing.

Example: I'd like to use "r" to launch "Radio 1" on top. However, if I create a hotkey trigger or a string trigger for that entry, typing "r" anywhere launches that playlist... That's not the idea.

What am I missing here? Is there no simple way to achieve this?

Thanks & cheers --Mike

Simply add a number to the macros' names. Then just type the number to launch the macro.

ā€”
Cary

1 Like

If you have a macro group configured to show a macro palette, then the macros it contains are only active when the macro palette is showing, so Iā€™m a bit confused as to exactly what you are doing and what your settings are.

Post the macro group (you can share the whole group to the forum, including an image of your macro group settings. If you can include an image of one of the macros as well, that would be helpful.

But basically you should have the macro group be configured to show the palette for one action after some hot key, and then the macros within it should have simple hot keys.

Alternatively, you can just leave the macro group set to active always and give all the macros the same hot key, and Keyboard Maestro will do the conflict palette for you. This is a better solution for this, but you should figure out where you are going wrong currently since that will help clarify Keyboard Maestro for you.

1 Like

THAT was my mistake...

I had a normal macro group, and showed it in a palette using

ad then

I changed that now to a macro group that "shows a palette for one action" and now it works as I expect.

Thanks!

Cheers --M.

Good. Yes, because the macro group was active to start with, the macros were active and the hot keys functioned even while the palette was not shown.

Now you have a deeper understanding, try instead making the macro group always active (like it was), and give all the macros with Control-Option-Command-I trigger. Let Keyboard Maestro handle the conflict and sub-hot key triggers.

Unfortunately it does not work for me. I just prefixed the macro title with "1. " and expected that I could hit ā€œ1ā€ after hitting the shortcut to open the palette.

If I understand the situation correctly, you have to do this following:

  1. In the macro group, do NOT specify a palette. In other words:
  2. Assign all the macros the same hotkey.

When you press the hotkey, you'll get a Conflict Palette:

Notice the slightly grayed 1 & 2. These are what you can press to select the macro.

4 Likes

Thank you so much, this had me thinking the right way to get the situation resolved for me.