KM Authorization "Automation" in Security & Privacy

Okay, I'll try to explain as best I can.
I don't understand English very well (I use translation)

I run a TEST macro and the variable is written in "preferences".
Like this:

But in the other macros I have.
Nothing is written when I run my macro ?
Like This


I wanted to know how this is possible?

  • The images you are posting do not provide enough information to evaluate.

  • Post your actual macro, so we can test it to see what's wrong with it.

  • Use the share function of the Keyboard Maestro Editor.
     
    image
     
    image

J'ai compris merci !

Voilà la macro:

  1. Setup Macro (v10.2)

1. Setup.kmmacros (44 KB)

@noisneil – would you please have a look at this, since you're a Logic Pro? (Pun intended...)

I also communicate with him and he does not understand why the variables are not written :sweat_smile:

Neil hasn't seen the macro yet...

I can only conjecture, because I don't have Logic Pro to test with.

However Neil does have and uses Logic heavily, and once he actually tests your macro he'll very likely understand exactly what the problem is.

You have a focussed window trigger, and you have a button-condition where Keyboard Maestro very likely cannot see the button.

Logic Pro's UI is very non-standard.

It's one of my macros, as it happens, and @sofiane14 messaged me to ask for help getting it working. Unfortunately we haven't been able to get past the fact that no variables seem to be stored by their KM installation. They've tried manually running a test macro that sets a single global variable; the variable viewer (prefs) shows it as blank, and that's not a problem I've encountered before.

1 Like

@noiseneil thanks for the clarification. That's exactly the problem.
@ccstone the TEST macro writes the variable but not Neil's macro. He didn't have this problem. And I don't see where it can come from...

It doesn't work at all on my system without Logic Pro of course.

Changing things around to make it work...

It fails every time on the compare button condition.

If I isolate this section and try it from the contextual menu it populates the variables:

image

But that's as fa as I can test without having Logic.

Have you actually tried opening a plugin in Logic in order to trigger the macro since you fixed your permissions issues?

by separating it works for me too!
@noisneil neil the problem may come from there?

No, that's not a problem; that's a feature. Open a plugin in Logic and see if the variables are written (spoiler: they will be).

What's happened here is that you've been testing variable-writing because you had permission issues. The Setup macro is designed only to run when a plugin UI is the front window. This is why I gave you a test macro.

So, long story short... Now that your permissions issues are fixed, stop checking that variables are writing and actually try the SD Switcher macro in practice.

1 Like

That's what I do every time.
I open a plugin to see if it works.
It still doesn't work.

By separating the groups as @ccstone did the variables are written and when I opened logic the profile changed. (the profile still didn't switch when I opened it)

And there by making it grouped, the variables are not written the profile does not change...

Can we get a quick call video?
I think the problem can be solved quickly.

Ok DM me a zoom link

1 Like

Yep, it's done

1 Like