KM Authorization "Automation" in Security & Privacy


In the security and privacy settings I can't get KM in "Automation".

I have tested everything

  • Allow all requests when I install KM
  • Restart the mac

My version is 12.5 Monterey

Can someone help me?

Can you drag it from application into there ?

Is the app in /Applications folder?

No it isn't possible...

Yes, KM is in the application folder

@RazMastero @hello Have you ever experienced this problem? I tested it on a friend's Mac and it does the same thing...

Can you share some pics ?


When I installed KM I accepted all the permissions.
But KM is missing in the "automation" part
I can't get it on.

KM should request authorisation when you ask it to automate another application for the first time -- you don't add the permission in advance.

What isn't working for you?

I had accepted all the authorizations that asked me.
I only had one request, which seems a bit strange to me.

I managed to get KM in "automation". But it is missing...
That's a good start.

I'll show you how I did it.
Maybe it will give you an idea to add the next step.

2_Icone KM Installation

Now I have to put "System" because I have only "Finder" with the manipulation I made.

Do you have an idea ?


That’s correct, KM will start asking for permission to automate more apps, like System Events, be sure to check :heavy_check_mark: those on as well.

After a while I’ll stop asking for more permissions as it already has the permission of those apps.

If anything else fails, remove KM and KM engine app and add it again in the Accessibility tab.

I have reinstalled KM many times.
For this time I removed all accesses as you advised me.
During the installation KM asks me for authorizations. Everything is set except in the tab "automation, system".
I don't understand because I am the only one to have this problem !
I can't use Keyboard Maestro because of this authorization that I don't have!

I am on Monterey 12.5
I'm trying to see if it's possible to force the authorization with the terminal.
If you have an idea...

So, if I understand correctly, you can’t check the System Events app?

@peternlewis might be able to help

Hey @sofiane14,

Try importing and running this macro.

Make sure both the macro and its parent macro-group are enabled after you import.


Attempt to Authorize System Events for Keyboard Maestro v1.00.kmmacros (5.3 KB)
Keyboard Maestro Export


Yes I have contacted him, I am waiting...

Hey thanks a lot Chris!

I tested it, it works!

While doing your macro I got a request for permission. I accepted it.

Thank you very much you solved this problem.
Thanks for your help guys.


@ccstone The variables are not being written when I run the macro.

Do you have any idea about this problem?

What macro?

If you haven't read this it's worth a couple of minutes of your time.

I took a macro that I downloaded for my work.

Look at this screen and you will understand

Whenever possible when asking for help upload the simplest possible test macro that demonstrates the problem you're having.

All kinds of important and fiddly information is hidden from view and not well communicated via pictures or prose.

If we're not testing – we're guessing, and that's not conducive to the efficient use of everyone's time.