KM no longer works after upgrade to macOS Catalina

I upgraded to Mac Os Catalina and now Maestro refuses to work. I can launch it but none of the macros will work.
I'm a bit desperate here, can anyone help?

1 Like

OK @Richard_Renner off the top of my head I would check 'permissions' and other things that allow access in preferences.

I believe the systems need you to give the app permission to access certain things. I don't know exactly what they are. Usually you get a pop up window telling you that though. I have had this happen to me after updates. I am sure an expert will soon chip in and give the exact answer. I will check round my system and see if I can find the exact setting.

Try this thread for clues with a contribution by Peter Lewis where he suggests various ways of kick starting permissions. Restarts and toggling often work for me I will say.

Simulate Keystroke Not Working in Mojave

I'd guess you probably missed one of the "Permission needed" prompts that came up following Catalina's install. (I'm sure you saw many others of those.)

I suggest going to the "Security & Privacy" preferences "Privacy" and see if there are any unchecked boxes next to Keyboard Maestro.

Nope. got all that done. Keyboard Maestro and the KM engine is checked in the Accessibility part under the privacy section.

Did a simple reinstall and that solved it. Probably a corrupt code in a plist that got replaced/corrected.


I have the same issue. Reinstalled, checked all security. Same issue. Any suggestions?

I was having persistent clipboard issues in Catalina, including after following the steps Michael listed as well as those on the KM wiki's Accessibility Permission Problem page.

Those issues now seem to be fixed for me. What did the trick was that I used AppCleaner to do a more thorough uninstall of Keyboard Maestro. From there, reinstalling and adding accessibility permissions worked as expected.

1 Like