KM11 Editor Beachballing on "...would like to access data from other apps." dialog


I'm running KM11 on Sonoma (14.1). I'm seeing a temporary freeze every time I use Keyboard Maestro Editor. From the editor, if I invoke the settings window with Cmd-, (mysteriously, this doesn't happen if I select the "Settings..." from the menu, I get the following dialog:

CleanShot 2023-10-29 at 16.28.24@2x

If I click "Allow" the app beachballs for perhaps 20-30 seconds. If I click "Don't Allow", it seems to go to the settings quickly. Of course KM won't be happy with "Don't Allow".

macOS doesn't seem to be remembering whatever answer I give as if I restart the editor and invoke the settings the same dialog appears. If I don't invoke the settings, the dialog will pop up at some point when I'm navigating around the editor, or when I'm trying to quit it.

Things I've tried:

  • Restarting KM
  • Reinstalling KM
  • Rebooting
  • Rebooting in safe mode
  • Checking the "Security" section in KM editor. All green checks.
  • Tried off/on these security options in macOS's settings app, restarting KM every time.

None of the above seems to have helped. The dialog keeps popping up, the answer is not remembered, and KM editor keeps freezing for a while.

The reason that dialog box appears is so that macOS can add KM into certain locations in the System Preferences application. Perhaps it (macOS) is failing to add KM for some reason. That would probably be macOS's fault, not KM, since it's macOS doing the work. (Perhaps you aren't logged into macOS as an admin? I'm not sure if that could be a reason.) You can check if KM has been added by opening up the System Preferences app and checking in certain places. The list of places that KM should show up is quite long and I'm not sure I should show them all here. The place with the most entries is probably "Automation" pane in the Privacy and Security tab of System Preferences. Do you see KM showing up in there? How many times do you see it in there?

I'm no expert at this, but I'm just trying my best to help.

Hi @Airy,

The dialog is confusing as it is unclear in what section of macOS's System Settings is KM getting authorized. I can see KM/KM Engine listed (and authorized) in Automation, Screen Recording, Files and Folders, Accessibility.

There's a bunch of apps listed under KM in the Automation tab which makes sense given my macros.

I'm a regular (admin) macOS user.

Okay. I'm guessing that macOS is giving you the beach ball because it (macOS) is failing to update the permissions in the System Preferences somewhere. This would be a macOS issue, not a KM issue. I suppose our next step is to compare all your permissions to all mine, to see where yours is failing. Like I said, there's a long list. Either I have to show you all mine, and you compare to yours, or you show me all yours, and I compare to mine. I would prefer the latter. Your brief verbal description isn't enough information for me to compare your system to mine. I would need to see screen shots. If we can find out what's not correct in your setting, that might be a clue as to why it's failing and/or how to fix it.

Or you can wait for other people to come up with ideas. It's your choice.

It sounds to me like one of your macros has a hot key trigger of , and it’s that macro that’s doing something to cause the confirmation dialog to appear; choosing Settings from the menu of course doesn’t trigger anything.

Check to see if any of your macros is triggered this way.

Hi @tiffle,

This is a good idea but I don't have a cmd-, trigger.

Even if I did, though, this wouldn't explain the issue with KM freezing up after I interact with the security prompt. This seems to be some weird case of KM interacting with macOS's increasingly annoying security infrastructure.

By the way, at least one other user has seen this problem: KM 11 issue: access data from other apps - #9 by Airy

it just that they got lucky and the issue vanished after a OS update.

I appreciate the feedback & ideas.

1 Like

All right, in case this is useful to anyone else:

@peternlewis had already answered this on a different thread about KM 10.2. The problem is... 1Password! Turning off the "Enable Spotlight and 3rd party app integrations" in the "Advanced" section of the settings solved my problem.

(I should add that in my case, I need to keep that option unchecked in 1P, as it creates problems with KM as soon as I turn it back on).