MACRO: [KMFAM] Favorite Actions and Macros

search
tools
workflow

#61

Figure out a macro for it, and you’ve got it made!


#62

I just added two steps to yours:


#63

That’s actually a good idea. I’ll have to think about that one. Thanks for the info!


#64

I’ve only tried it on a few actions, and I haven’t tried it on any macros. Also, it may not work on different resolutions.


#65

You won’t need it on macros. I get tricky for them. :slight_smile:


#66

@DanThomas I think something needs tweaking after the 7.3 update. Saved images now appear at the bottom of your preview window:


#67

They don’t on my machine. Do you have a Retina display?


#68

I do. I didn’t have this issue before the update. Let me see if downloading a fresh verison of your macro helps.


#69

I don’t think that would matter. Have you tried rebooting? (Please, please let this fix it. :slight_smile:)


#70

Rebooted and installed fresh copy of KMFAM, still shows at bottom. I have disabled syncing on my second laptop and that one running KM 7.2 does not have this issue.

Laptop #1 Running KM 7.3:

Model Name: MacBook Pro
Model Identifier: MacBookPro12,1
Processor Name: Intel Core i5
Processor Speed: 2.7 GHz
Number of Processors: 1
Total Number of Cores: 2
Memory: 16 GB
Boot ROM Version: MBP121.0167.B17
SMC Version (system): 2.28f7
Chipset Model: Intel Iris Graphics 6100
VRAM (Dynamic, Max): 1536 MB
System Version: OS X 10.11.6 (15G1004)
Kernel Version: Darwin 15.6.0
System Integrity Protection: Enabled
Time since boot: 7 minutes

Laptop #2 running KM 7.2.1:

Model Name: MacBook Pro
Model Identifier: MacBookPro12,1
Processor Name: Intel Core i5
Processor Speed: 2.9 GHz
Number of Processors: 1
Total Number of Cores: 2
Memory: 8 GB
Boot ROM Version: MBP121.0167.B17
SMC Version (system): 2.28f7
Chipset Model: Intel Iris Graphics 6100
VRAM (Dynamic, Max): 1536 MB
System Version: OS X 10.11.6 (15G31)
Kernel Version: Darwin 15.6.0
System Integrity Protection: Enabled
Time since boot: 16 days 21:12

P.S.: Thank you @Tom for the system info tool :slight_smile:


#71

Thanks for the detailed info - that’s exactly what I would have asked for.

This happens for all actions, not just newly-added ones, right?


#72

No, only newly added. Foolishly, I deleted the actions that were added a few days ago, so I cannot show them to you. I’m sorry. They still had the correct image though.


#73

OK, well, that’s actually good, because I know where to focus. But since I don’t have a Retina display, I’m going to need some help.

If you’re willing, can you do the following?

  1. In Finder
  2. Go to the KMFAM Resources folder
  3. Drill down to prefs/KMFAM.whatever.prefs/Images
  4. Sort by date, and find the newest image.
  5. Post the image here.

Thanks.

Foolishly, I deleted the actions that were added a few days ago, so I cannot show them to you. I’m sorry.

No worries. I believe you. :slight_smile:


#74

Technically, the newest image is this one, from Laptop #2 KM 7.2.1:

But I think the one you’re after is this one (one minute older) from Laptop #1 KM 7.3:


#75

Holy Cow! I had no idea that was happening. Just to double-check what I think I’m seeing:

The image that aligns at the top (the pre-7.3 image) actually has a bunch of blank space at the bottom of the image?

Can you, in the KM Editor, select an action and do a “Copy->Copy as Image” and see if it also has blank space in it, top or bottom? In either version of KM. I want to see if I’m adding the blank space or KM is.

I hope that makes sense.


#76

Yes, there is white space.

Here is the Copy As Image from Laptop #1 Running KM 7.3

And here is the Copy As Image from Laptop #2 Running KM 7.2.1


#77

You’re copying the macros. Select an Action then copy it. Thanks!


#78

Sorry, edited above.


#79

You said “Yes there is white space”, but the images don’t show that big area of white space the previous images show, so I guess I should have qualified my question:

The images from the prefs/Images folder in preferences look like they are about twice as tall as they should be, with a bunch of white space either above or below the image. The images you just posted don’t have that issue.

Does that sound right?


#80

Correct, the white space is only in the images found in the KMFAM pref folder, not when I copy the action directly from KM and paste it here.