Macro Works Only via "Try" – No Hot-Keys Work?


  • Always make certain both the macro and its parent macro-group are enabled and active in the context you're working in.
    • I.E. a macro in a Photoshop specific macro-group won't work in the Finder.

Good morning!

My hot-key problem is still around, at least now as regards Adobe Photo Elements 2020. After spending a whole day of trial and error, yesterday, I finally put together two Macros that work (whoopee!), but only if I hit the "try" button within KM editor itself.


No hot-key variation that I have tried does anything. One possible problem is that Adobe uses quite a few itself, but even if I try some utterly weird combination, nothing happens. I am running macOS Catalina, any ideas out there?

1 Like

I had the same problem with another application until i found out that the app was not activated. Is this maybe the problem here too?
Try activating the app first.

If you mean by "activated" that the program is running, the answer is yes. I have Adobe up and running, but "nada"....or have I misunderstood something?

No, you didn't. Don't know what the problem could be then.

Incorrect. When using KM, "activated" means the app is running AND is the frontmost app.
See Macro Activation .

The KM "Try" button will never work properly when the Macro is in a Macro Group that requires a specific app to be Active (frontmost).

You need to add to the beginning of your macro an Activate Specific application command:


But it is ONLY the "try" button that works! No hotkey works, no matter what I put in.

Aha! But why does "Try" work then?

Nope! No joy with that, either... now not even "Try" works, bummer!

But putting in "Bring Front Window to Front" made "Try" work again, for some reason... but the hotkeys don't!


It's a mystery... enough for today. Two days spent on this, time for a break :frowning:

Oops! I forgot to make it clear that only the hotkeys for Adobe Elements 2020 fail to work... all my "old" hotkeys work.

What's up with that, then? Good night.

as to why Try works, must be because it's right behind KM

Can you delete keyboard shortcuts in Photoshop Elements? so the key combination is free to use in KM.
I know for sure you can remove them in Photoshop CC.

have you tried a hotkey such as Cmd-Shift-Alt-Ctrl-J? Pretty sure something elaborate is not used.

As explained in Tip: How Do I Get The Best Answer in the Shortest Time, you can save a lot of time, and get better help, if you will upload your macro , both the image and file. The file will include your Macro Group, which is most likely where the issue resides.

I don't know whether it solves the issue, however in my case the hot keys I assigned did absolutely nothing until I enabled the macro group the macro belonged to just now, as I started reading this thread. It appears that when a macro group is inactive it doesn't fire its macros your hot keys combos regardless. It can be just this isolated case that worked and in other cases it may not but it helped me.

1 Like

If the macro group is not enabled, that would explain why "Try Action" works but the hotkey doesn't. I'd bet dollars to donuts that this is the root of the problem.

1 Like

This old thread helped me today – the Macro Group was indeed the source of my problem.

I had forgotten that the Group had to be activated by its own hot key.

All fixed now...