Macros not working in Mojave Beta 3

since updating to Mojave (currently beta 3), when pressing the hotkey cmd shft J for my action, nothing happens! every time I open the pap I get a km prompt to allow accessibility permissions which are already allowed, including the engine.

have tried reinstalling, dragging engine into sys prefs, shutting down. I can now see that macros do initiate however and action such as move/click mouse is not completing. I still get alerts saying I have not enabled permissions.

seems to work now. not sure what I did

although my macro now works I am still getting pop ups asking to enable permissions, I also cannot edit my macro: with the type keystroke action there is an entry box which records your desired key, when I select this it is the unresponsive to any keypresses. there is also sill a "!" alert at the bottom of the window which requests I enable permissions

See announcement from @peternlewis:
Don’t “upgrade” to Mojave beta 4

A post was split to a new topic: Hot Keys Don't Work After Upgrade to Mojave