Macros Not Working

I have a few macros that have stopped working as late. A few of them just involve pasting of some letters as well as emptying the trash. Any assistance would be appreciated.

You need to provide us with a lot more info in order for us to be helpful.

Let's start with this:

  1. When something unexpected happens consistently, ask yourself what has recently changed about your system: macOS updates, new apps, app updates, and especially any untilities
  2. Always post what versions of macOS and KM you are running.
  3. See KM Wiki on Troubleshooting

If all else fails, try Start up your Mac in safe mode. Then launch KM and test your macros. If they work fine then it is something else causing the problem.

Please read:
Tip: How Do I Get The Best Answer in the Shortest Time?

I’ve re-imported the macros safely. Some work but the ones that involve pasting a few words don’t.

Here are screen shots of two that are not working.

I see your example macros are placed the Work in Progress macro group, which is deactivated. No macro in that folder will be triggered by hotkey.

I see that the empty trash is there but not the Insert Type by Typing.

How would I go about moving the file from Work in Process? It won’t allow me to drag it out.

You can drag it to another macro group, such as “Clipboard” or “Global Macro Group”.
Not the purple icon ones. They are smart groups.
The macro must be in a macro group. You can only drag it to another group.

When you are in the “All Macros” smart group and drag a macro to another group, the only difference you can notice is the group name at the upper-left corner, which indicates which group it belongs to.

Since you are in "All Macros" smart group, all macros should show. You can further search the macros. See:

If you can't see it or find it, it means the macro does not exist...You may have deleted it.

I’ve moved various macros to Global Macros but still when I try to add a Hot Key it is not accepted. I’ve tried the same in the tutorial program and even there when I reach the point to add Hot Key the same thing happens.

Hi @mackinnon8467, you need to be more specific for others to help you.
What do you mean by "Hot Key is not accepted"? Not successfully set? Successfully set but not triggering the macro?
Things will help:

  1. If it is the former, you need to upload a screenshot or a gif or a video recording to let others see what is on your screen as you did previously.
  2. If uploading an example macro helps, upload a macro with a screenshot of the macro.
    To upload a screenshot of the macro, you can do "⌘-A" to select all actions in the macro, then right-click and choose "Copy as Image". Then you can directly paste the image to the post.


It’s not successfully set.

What hotkey did you try to set?

I’ve tried a number of “ F “ keys. I’ve used these successfully before. Strangely enough, some of the actions are still working such as opening applications, folders and documents.
I’ve done nothing over the last few days that would cause some of these actions that were working previously to stop working.

Hi @mackinnon8467, I'm still confused by your posts.

"Not being able to set up a Hotkey" and "some actions being not working" are different things. Do you have both issues or just one of them?
If you have both issues, it is better to make two separate posts.
I'm sorry. Given your information, I can't be of much help.
Maybe someone else can jump in and help out.