Mojave clipboard behavior and workaround

Just upgraded to Mojave and all my macros with clipboard Paste actions stopped working. My workaround was to insert a 0.25 second pause in front of each Paste action. Not a question - just sharing.


There are no other reports of anything like that, so I think there is probably something going on on your Mac.

A lot of people have had accessibility issues until they toggled the accessibility checkboxes, but a Pause presumably would not resolve that.

Hello Peter,

Unfortunately he's right - I had exactly the same issue, but this is really weird. I had a MacBook Pro model 2017 with Mojave, and migrated over the weekend to a new MB Pro, also with Mojave (nothing beta).

I have a KM shortcut that I use all the time: it strips all styles from the clipboard and pastes plain text. It worked fine on my previous MB Pro, but did not work after the migration. Using @bdurham's suggestion it solved the issue... 0.1 seconds even work. 0.05 seconds as well, but not reliably.

Completely similar: I have a KM shortcut that types (by pasting) my email address (, I use that often as well. After the migration, it pasted "" - I was completely baffled. I came accross this problem before the paste problem, and not knowing what the solution could be, I changed the string to "", which works fine; but adding the 0.1 seconds pause solves the problem too. So there is something that changed in the way events are handled?

What I cannot grasp is that one Mojave on a 2-year old MB Pro is different from another Mojave on a new MB Pro. Is it because it's faster? Baffled.

Thanks & cheers --Mike

I agree, that is baffling. :frowning:

I just migrated from an 2015 iMac to a 2019 iMac, and have not seen this issue.
However, on my 2015 iMac I did occasionally see the dropping of the first character of the pasted text when I used a KM Typed String Trigger, but never with a hotkey trigger.

To narrow down if this is some KM issue, I'd suggest restarting your Mac in Safe mode , and then start only the KM Engine, and test.

OK, tried it in safe mode and indeed it worked without extra delay. But the really strange thing is that now it is working again without delay in normal mode... So there was no doubt some process hogging attention and that isn't there anymore? Even more mysterious.

Thanks & cheers --Mike

Booting in to Safe mode cleans out a lot of caches and rebuilds a lot of things, so it is probable that that was the issue.

Not impossible - what I remarked was that it took much longer to boot in safe mode than booting in normal mode, and that initially my Mac was simply sluggish... Is that those caches being cleared and the consequences of empty caches?

Thanks --Mike

Possibly, I don't really know what Safe Boot really does.