Move selected file/s to folder


I am trying to use the new move function. What I would like to do is select one or multiple files in Finder by selecting from a list of buttons I want to move the file to Pre-selected folder. I looked at the online users guide, and all I can find is all examples of how to move a file, but can’t figure it out. Can somebody point me in the right direction on how I can accomplish this

Thank you..

Have a look at this:

I don’t know how close that comes but you can change it if needed or just search the forum for other ideas, just like I did!

Here's my take on it:

Move Selection to Favourite Folder.kmmacros (41 KB)

Macro screenshot

Notice that if you format a favourite folder path as below, the string after the double-underscore will be the name visible in the list prompt. Otherwise, you'll just see the folder name as it exists.

~/Documents__My Docs

1 Like

Thank you. Perfect.

1 Like

Hi again. Ok. What is the best way to add additional folders to move. I created a folder on my desktop TEST. Using Path Finder I got the UNIX path, which is showing as:
/Users/username/Desktop/TEST and add It to the list in a similar format, using
~/Users/username/Desktop/TEST, the list is not showing any of the folders. What am I doing wrong?

Thank you.

Enable the green action.

OK. That is now showing the list. When I add a folder to the list and use it, I am getting the following error: (I added this to the list:
/Users/username/Library/Mobile Documents/com~apple~CloudDocs/@@@Downloads All
CleanShot 2023-12-04 at 06.59.09@2x


/Users/<YOUR ACTUAL USERNAME>/Library/Mobile Documents/com~apple~CloudDocs/Downloads

If i use the name "test" as the folder name, it works. I use @@@ in the beginning of the folder names to put them on the top of the folder list. You think thats the issue?

@noisneil was just trying to point out this:


You need to change username to your user's actual short username.


1 Like

I did that. It is reading this: For example,
/Users/muratkilci/Library/Mobile Documents/com~apple~CloudDocs/Digital Assets

Still not recognizing it. You think the space between the last 2 words at the end is the issue? (Digital Assets). Digital (SPACE) Assets
OK. i tried this. Still not working after removing the space.

No. I just tested and it's fine here.

It works here for my ...CloudDocs/Downloads folder. I'm assuming the folder does appear in the prompt but the file move fails. Is that correct? I can't think why this might be failing, as I can't replicate the issue.

It works completely? In that case, I'm stumped as to why it doesn't work for your cloud folders.