New M1 Mac not recognising Keystrokes

I have a new M1 MacBook Pro and can't get any of my Macros to work using the keyboard hotkeys. They work if I click 'Try'...but not if triggered by their hotkeys - I just get a 'beep'!

I have restarted everything and given KM all the permissions in accessibility and Full Disk Access.

I would be really grateful for any suggestions on how I might fix this?

Thank you

any app in particular? or none of the macros work, no matter what app?

tried toggling the permissions On and Off?

Thank you. It is all apps and I have tried the toggling on and off and that hasn't worked.

If Keyboard Maestro cannot see keystrokes, the options are basically:

Things to try include:

  • Restart.
  • The Interactive Help (in the Help menu).
  • Things covered in those documents listed about.

There are no current bug reports particular to Apple Silicon / M1.

Thank you.

I spent 24 hours playing with the secure input and quitting 1 Password/Text Expander etc and reinstalling and toggling the permissions and then it just worked. Hurray.

Thank you for taking the time to reply.

This is a good tool to keep around for just these types of hiccups: