Problem using Press Button

I am using 10.2 and just discovered the Press Button action. I wanted to do a simple test to see if I could get it to press a button called Start a New Game. I've included some screenshots to show how it normally looks and the info that comes up when I inspect the element. The later seem to indicate the name of the button is indeed "Start a New Game".

When I run this macro it does bring the Chrome window to the front, but then I get an error saying it didn't find the button.

Is the problem that it is in a group of buttons or maybe I have the wrong name for it? Is there a way to use Press a Button with this?


If you decide to upgrade to KM11, you may be able to use the new button press functions to do this.

Until then...

Thanks for the fast reply, but any idea why the Press Button isn't working? I'm a bit leery about going to 11 when the screenshot you pasted in starts off with "I want to go back to Version 10".

Also, I've tried using links before, but I found them unreliable - which I think might be due to the web page being changed. Instead, I most often use the Find Image tools. One problem with the the Find Image tools is that an image may change its location as a page loads. Because of this I often have to find it a 2nd time or build in pause X seconds or a pause until page loads at least X seconds command (which doesn't always work either unless I put in a pause that is bigger than I'd like).

I was hoping the Press Button tool would work even if the location changed as the page loads.

The Press Button action in KM 10.2 doesn't work with web pages and web apps like the one you're using. It is designed to work with the buttons you get in native Mac apps.