Simulate Keystroke Not Working in Mojave

After updating to Mojave Keyboard Maestro doesn't appear to be simulating a keystroke. I designated a hotkey to execute an Applescript, simulate a keystroke (cmd-opt-L), then run another Applescript. The Applescripts execute with no issue but the keystroke doesn't appear to to be generated.

Apple’s Accessibility permissions seem to be (surprise surprise) somewhat dodgy.

Either toggle the Accessibility permissions for Keyboard Maestro and Keyboard Maestro Engine off and then on again, or try restarting.

Same problem here

Possible solutions are:

  • Relaunching the Keyboard Maestro Engine (Quit Engine, Launch Engine).
  • Restarting
  • Toggling the accessibility permissions for Keyboard Maestro and Keyboard Maestro Engine off and then on again (probably while Keyboard Maestro and Keyboard Maestro Engine are not running)
  • Run the Terminal command “tccutil reset Accessibility” (probably while Keyboard Maestro and Keyboard Maestro Engine are not running) and then launch Keyboard Maestro and allow the permissions.
  • Quit Keyboard Maestro and Keyboard Maestro Engine, trash the Keyboard Maestro.app, empty the trash, download a fresh copy from https://files.stairways.com, use the Finder to move the Keyboard Maestro.app to the /Applications folder, and retry any of the above.

If none of that works then I am out of suggestions and until some other thing presents itself it may require a fix from Apple.

Thank you. Toggling the accessibility permissions didn't work so I went straight to trashing and reinstalling KM. I set permissions when KM asked and now it works.

Since installing Mojave I have had several apps request accessibility permssions only to find that they were already set correctly.

None of this solved it for me :frowning: I've trashed system prefs. Re-installed KM. Tried v7 and 8. Re-added the permissions. Re-started the computer.

Simulate Keystroke doesn't work in Mojave.

Is there a fix out there?

What specifically is not working? Toggling the accessibility permissions (System Preferences, Security & Privacy, Privacy, Accessibility) for Keyboard Maestro and Keyboard Maestro Engine off and then on again is generally required if you upgrade to Mojave with Keyboard Maestro already installed.

Also, simulated keystrokes that are intended to trigger hot keys in the system or other applications do not work in Mojave unless they are letters (optionally with modifiers). Simulated arrow keys or function keys do not trigger hot keys due to bugs in Mojave. This may be fixed in a future version of Mojave, or I may find a workaround in the future. In the mean time you may be able to adjust your hot keys to to use letters instead of arrows or function keys, and then they can be simulated from Keyboard Maestro.

Other than those there does not appear to be any systemic issues with Mojave.

Reinstalling Keyboard Maestro is unlikely to ever fix pretty much any issue. Installing a previous version is more likely to cause problems than solve anything.

1 Like

I have the same problem, and tried all solutions to solve it but the problem still exists.

I beat my head against the wall, tried all the recommended solutions and so forth until I read this message. And, thanks to you, I solved the problem!

In my case, I was trying to invoke Mission Control with the ctrll-Up Arrow. The work around was to open the Mission Control.app instead..

Just an update - I have looked in to it and cannot find a viable workaround. And there is no evidence that Apple intends to fix this, but who knows, maybe they will.

I was able to get Keyboard Simulated Keystrokes by following these directions I found on the Moom website. I ended up having to do the "The Somewhat Harder Fix" of deleting and reinstalling the application. However, finally it worked.

https://manytricks.com/osticket/kb/faq.php?id=112