Simulate Keystroke Not Working in Monterey Please help

Purpose of Macro: type K to trigger a keystroke Command K (this enables pre-roll in Pro Tools) It will speed things up a bit with single keystrokes. I was able to do this months ago with other shortcuts and they still work, but cannot be changed now.

Issue: When clicking in simulate keystroke field, I cannot type anything

I have been on Monterey using KM for a year. It has been fine. When i click on the simulate keystroke field and type, nothing happens. I have been on this for hours now, and installing the older version did not work either. I have tried all suggestions I can find online including:

  • Relaunching the Keyboard Maestro Engine (Quit Engine, Launch Engine).
  • Restarting
  • Toggling the accessibility permissions for Keyboard Maestro and Keyboard Maestro Engine off and then on again (probably while Keyboard Maestro and Keyboard Maestro Engine are not running)
  • Run the Terminal command “tccutil reset Accessibility” (probably while Keyboard Maestro and Keyboard Maestro Engine are not running) and then launch Keyboard Maestro and allow the permissions.
  • Quit Keyboard Maestro and Keyboard Maestro Engine, trash the Keyboard, empty the trash, download a fresh copy from , use the Finder to move the Keyboard to the /Applications folder, and retry any of the above.
    Pre Roll .kmmacros (2.5 KB)

And welcome to the forum!

I might be stating something the obvious, and something you are very much aware of here; but out of the image you’ve added I read the problem as being the Simulate Keystroke field not being filled in. You’d need to click the field where it now says Type and then press the key, or combination of keys, you want this action to simulate.

If it is not this that is the problem, and the macro you are trying to get to work on your end have the Simulate Keystroke field filled in we’d need to know more what it is you want your macro to do, and how it is not working, for others to be able to help. Uploading the actual macro file is also aways advised.

How Do I Get The Best Answer in the Shortest Time to Questions on the KM Forum?

Edit: See now that @Airy bellow, maybe correctly, interpreted your post as stating the problem to be with the editor and not being able to create a new macros.

You said "you cannot create new macros". That's puzzling, because your screen image shows a new macro. The KM Editor is the application that creates new macros, so all your work with the KM Engine isn't really pertinent. Can you clarify what the problem is? You circled an action in a macro in your image. Is the problem with the action? I see you didn't insert any key into the "Simulate Keystroke" field. Maybe that's your problem? I'm trying to help, I'm just not sure what the problem is yet.

Thanks Alex - appreciate the help! I have revised the post to meet the criteria you suggested and included the KM file.

I use KM for Pro Tools. I simply want the letter K to trigger command K. I successfully got this going with various other shortcuts (which still work, but cannot be changed due to the same issue) when I setup KM and now I cannot type in the simulate keystroke field. Hope that is clear and succinct enough.

1 Like

Thanks so much Airy - I revised the post and included the KM file and answered Alexander with more details as well. I use KM mainly for Pro Tools. I want K to trigger K and Command. I have this working with a bunch of other shortcuts which still work, but cannot be changed due to the same problem. When I click the simulate keystroke field, I cannot then type anything. I also noticed when selected, if I type command K it pulls up the action list, which tells me there is an issue filling out this field. Appreciate any advice, and hope this is clear enough

Thank you so much for you clarifying revisions. This behaviour is indeed puzzling. Is it only Cmd+K you are not able to write into the Simulate Keystroke field? Or does this field on your end not accept any input what so ever?

I was thinking the issue might be that the typing of the K on your USB keyboard triggering this very macro was somehow blocking you from entering Cmd+K into the field, but as your macro would only trigger if Pro Tools is at the front this is not the case. Sorry for not being able to be of more help as of now, but hopefully someone else will come up with a solution.

In the meantime, and as part of the problem solving: Does this version of your macro where I’ve entered Cmd+K into the Simulate Keystroke field work for you?

Pre Roll Macro (v11.0)

Pre Roll.kmmacros (2.5 KB)

Once he answers your question, if it still doesn't work, we should ask him why he's using "USB Keyboard K" instead of a hotkey "K". I can't even create "USB Keyboard K" because that seems to require a special keyboard that I don't have. All I have is an Apple keyboard. So I can't copy his problem.

Very good point.

It indeed does - thanks more sending it. I can now use the shortcut, but still cannot type anything in the field.

Typing anything into the field does nothing for me.

The keyboard i am using is a pro tools style KB keyboard:

There's a good chance that the problem is in the keyboard, because that's a very complex keyboard (with a 1400 page manual) that probably can replace its standard USB scan codes with USB device codes for each key. If its scan codes were disabled, that would precisely explain why the KM editor is not recognizing your keys. If you replace that keyboard with an Apple keyboard, your problem would likely disappear.

This is my working theory at the moment. It's not a bad theory, but it may not be right.

Thanks so much Airy - I have an Apple magic keyboard too - the problem is consistent with that keyboard as well - AND with the magic keyboard, i cannot type in the "triggered by any of the following" where I could press K with the USB keyboard!

Also just for reference, I have ONLY used KM with this Pro Tools labeled USB keyboard before and everything worked until I updated KM. I then reverted but the problem persists, so I do not think it is the update per say!

If you cannot type in to the field, there are three likely causes:

  • Keyboard Maestro or Keyboard Maestro Engine does not have Accessibility Permission
  • Secure Input Mode is on

or, my personal favorite, and likely the cause of your issue:

  • Keyboard Maestro and Keyboard Maestro Engine has Accessibility permission, but is listed in Input Monitoring and that is not enabled.

Once you resolve that, you can create a macro that use the Hot Key trigger (not the USB Device Key trigger) to capture the “K” and then type the Command-K.

Thanks Peter - I am still unable to even with all of these steps - any ideas?

Hot key trigger will not let me type either, and this problem also happens on Apple Magic Keyboard

Screen Shot 2023-10-30 at 8.55.50 AM

Screen Shot 2023-10-30 at 8.55.55 AM

Screen Shot 2023-10-30 at 8.56.02 AM

Almost certainly, despite all the above, Keyboard Maestro does not have accessibility/input monitoring permission.

At this point, I would try two things, Restart and reinstall the Keyboard Maestro app.

  • Quit Keyboard Maestro and Keyboard Maestro Engine
  • Make sure you have no other copies of Keyboard Maestro on you Mac except the one that is in the Applications folder.
  • Download a fresh copy from:
  • If the file is still a .zip file, unzip it.
  • Use the Finder to move the resulting Keyboard application to the Applications folder (replacing the one that is there).
  • Launch the Keyboard Maestro app from the Applications folder.

Reinstalling the application can sometimes resolve connection issues for the security system.

Failing that, the only remaining option is using tccutil to reset the Accessibility and Input Monitoring permissions, restarting and trying again.

Thank you peter

I tried deleting and re-installing already - unfortunately. I even installed the previous version to see if that would help.

I want to try again
Would you mind extending the instruction to include every step in the exact order including the re-install? I am really hoping we break through I love KM and hope it can work!

I don't know which steps I can clarify further.

  • Quit the Keyboard Maestro Engine by selecting Quit Engine from the Keyboard Maestro status menu.
  • Quit the Keyboard Maestro editor.
  • Use Spotlight or the Finder to search for the Keyboard Maestro application on your Mac. There should be only one. It should be in the Applications folder (it doesn't have to be, but for simplicity this is the best place for it).
  • Download a fresh copy from:
  • If the file is still a .zip file, unzip it.
  • Use the Finder to move the resulting Keyboard application from the Downloads folder to the Applications folder (replacing the one that is there).
  • Launch the Keyboard Maestro app from the Applications folder.

Ensure that Keyboard Maestro and Keyboard Maestro Engine is listed and ticked in the System Settings, Security & Privacy, Accessibility permissions. If either is listed in the Input Monitoring permissions, ensure that is ticked as well.

If that does not work, Restart.

If that still does not work, then you will need to use the tccutil tool to reset your accessibility permission system (and maybe the Input Monitoring one as well).


This worked! (Sorry for late reply)

I am actually glad you laid out exact steps, since I’ve trashed KM a few times and followed these steps to no avail before. The only difference is I replaced KM instead of trashing and somehow everything works now

Thanks so very much!

1 Like