[Solved] Cannot Paste From Keyboard Maestro Using StreamDeck Into Unreal Engine


Here are the steps:

  1. I copy a component from Unreal to clipboard (pasted it to Notes to test, copied that and paste it back into Unreal and it works)

  2. I then paste that code into a new KeyboardMaestro macro, assign a streamdeck button using a keyboard maestro built plugin for the StreamDeck. Simple. Copy named Clipboard "MakeTransform" to System Clipboard then Paste Action

  3. When inside Unreal, I launch streamdeck button and nothing appears in Unreal

Ok, so I then launch the button in Notes, paste those lines of text back into Clipboard and paste into Unreal, it works. So there is something wrong with Keyboard Maestro.

I loaded up both clipboards in Visual Studio to compare both files and they both look identical.

Please help.


Hey Ben,

Post your macro that's failing.

How to Post Your Macro to the Forum

If you haven't read this it's worth a couple of minutes of your time.

Tip: How Do I Get The Best Answer in the Shortest Time?

Take Care,

(Keyboard Maestro Moderator)

Hi Ben, it looks like this is your first time posting here, so first off, welcome! This is a great forum with very knowledgeable folks who are always eager to help. Since it's your first time posting, I imagine you might be relatively new to Keyboard Maestro.

I myself have thought this from time to time when something has not worked the way I expected. I have always been wrong :wink:

I can confirm that Keyboard Maestro and Stream Decks work great together, so it's likely something very simple that has been overlooked while setting up your macro. Like Chris (ccstone) said, if you post your macro itself, it will let us look at it and see exactly what the issue might be.

Here is my macro:

MakeTransform Macro (v9.2)

MakeTransform.kmmacros (6.4 KB)

I’m a little confused about what you’re trying to accomplish, but let me see if I understood.

You are copying something from unreal, and manually pasting it into the KM macro? Then from inside Unreal you run the shown macro which sets the text you just pasted in to plain text and repastes it in Unreal?

One thing I noticed…

You mentioned copying the named clipboard to the system clipboard but I don’t actually see that part in your macro. Is there another macro that invokes (or is invoked by) this one?

I’m not home right now (and I’m trying to figure this out on my phone haha) but let me know if I understood correctly or not and when I’m back home I’ll jump on my computer and take a closer look.

I just tested your macro in Apple Notes (I don't have Unreal so I can't test it there), but it pastes the text just fine. If you could provide a little more detail from my questions in post 5 we can go from there.

Just a hint : in KM editor you have "Interactive Help" in the help menu. You can follow the question "Something expected is not happening". Either you will find what goes wrong or it will rule out some of the common problems. If the latter, report here for the search of uncommon problems !

Eventually found out what the problem was. So it doesn't look like its on Keyboard Maestros end.