Spotlight General Purpose Search (macOS)

Yup, that's it! I had different shortcuts set up for SL searches. When I restored them to what you specified, your new macro worked!. The key issue seems to be that the default for a Finder SL search in HS is option-cmd-space, not ctrl-space:

However, the problem is that making these changes broke the old macro! So I'll just go back to my old shortcuts, and continue using the old macro.

1 Like

Hi. this macro doesn't work for me. Is that because of the version of KM? mine is 7.3.1. Also I would like to search my tags. is that possible?

I seem to be repeating myself lately:
We're pretty good around here, but we have not quite mastered reading minds, yet. :wink:

For us to help you, you have to first read and follow this:
Tip: How Do I Get The Best Answer in the Shortest Time?


You are right. I do apologize. The macro worked only one time for me. The macro opened my Finder and typed slowly my text on the search bar, but after that, it doesn't run.
KM 7.3.1
macOS 10.13.3

This could be an issue with High Sierra. I think KM 7.3.1 is OK.
It still runs fine for me in Keyboard Maestro 8.2.2 on macOS 10.12.6.
I have no way of debugging for 10.13, since I don't have access to a machine running that.