Text expansion triggers but, nothing happens!

Just a quick update because i'm STILL trying to figure this out...

It seems that the bottom line is that KM won't (can't) trigger text "in line" like i'm asking it to.

It MUST be a conflict somewhere because i created a "Display text in a window" macro and it works just fine. i also added a "Speak Text" action after my "Insert Text" action and i get the speech but no text.

i've gone into my Security & Privacy settings and disabled Accessibility access for TextExpander and Alfred just in case they were conflicting. i even changed the trigger to a hot key...just for fun. It just won't paste text in place like it should.

i want to do a simple thing and it's now sucked up 2 days of my time and it's driving me crazy!

We want to help, but you need to post either the macro or a pic of the macro that is causing you problems.

https://wiki.keyboardmaestro.com/Forum on how to upload macro

Try this and see if does what you want
Assumes search field is blank.

Bonjour, @jonathonl. Thanks. i'm uploading the macro now.Gmail - search Inbox.kmmacros (1.4 KB)

This works exactly as expected...

OK This may be folklore but use type rather than paste
You can modify my example to move to search field, select all, delete and then type

Thanks again, @jonathonl. i think that's what i did: used type rather than paste.

i don't think your solution includes my original criteria of adding "label:inbox" before the address i want to search so that it only searches in the Inbox.

You also didn't upload the macro i don't think. It also looks WAY more complicated than what i think i need but if it works....:man_shrugging:t2:

But, above all, it doesn't address the issue that KM doesn't actually type the text that i'm telling it to. As i mentioned, i have other macros that i downloaded from someone that has much longer text and those don't work either. Shouldn't we address the core issue?

Thanks again. i like the program and this forum is quite useful.

Please , look at prepend text action and modify as required

Ok, i'm working on setting it up right now.

OK Goodluck
The only issue I am aware of is that KM can type too fast for the host computer, meaning dropped/repeated characters, there are number of very easy solutions to that problem.

i don't see Prepend as an Action.

Copy
Set text
Prepend

The set variable to text can be modified "in situ" to
prepend, overwrote, append, so it is the set variable action you want

Click on action cogwheel to change.

After I added a Typed String Trigger, your macro works fine:

image

Here's a very short demo:

Sounds like you are fist punching your keyboard. It’s probably abused. Just joking... somewhat.

Anyway, Are you on Catalina by any chance??

Can you see this post and make sure you perform these steps before we go any further?

KC

Ok, i've completed started over. Reinstalled. Unchecked and rechecked the accessibility preferences and it seems to be working now. Thanks everyone for the help.

@kcwhat Nope. i haven't upgraded to Catalina yet.

A final quick post about how i finally got to the workflow i'm happy with now. i'll surely add to this later but for now this is what i've got...three macros:

  1. Control–F19 (extended keyboard): this takes a contact email address that i've copied, highlights the search bar, types in "label:inbox" for searching the Inbox for emails that that contact

  2. Control–* (extended keypad): selects all the emails returned in the search (50 at a time is the limit) and archives them all at once. i can trigger this one more than once to delete 50 at a time.

  3. Control–- (minus, on the extended keypad): this returns me to the Inbox so i can continue.

i'm so thrilled to have gotten this working. i'll develop more complicated workflows as i get better with KW.

Thanks for all that helped: @kcwhat @JMichaelTX @jonathonl

Ok, back to sorting email....just a few more to go!
image

You're thrilled............ How do you think we feel? :slight_smile:

:zipper_mouth_face: :stuck_out_tongue_closed_eyes:

That Accessibility Permission bug started in Mojave.

Catalina made it worse, in some cases refusing to allow you to turn on the checkbox, but the bug requiring toggling started in Mojave.

2 Likes

Yep. That’s why I pointed him to your accessibility post (above). Oh well. :smiley:

1 Like