Text expansion triggers but, nothing happens!

This must be the most basic and idiotic of problems but... KM Assistance tells me that my text expansion shortcut is activating...but nothing actually happens.

The way i imagine it working is i type three characters (;li) and those three characters should be deleted and other text should appear. But nothing happens...

i've restarted my Mac and have tried everything i've read to solve this. What am i missing?

Sorry for the basic question. i'm generally known to be quite advanced with MacOS.

Thanks in advance!

Is the macro enabled? Is the macro group enabled?
Run the Help } interactve help assistant

Is the field you are using protected in some way?

PL try if a new macro that has
if i type say zxkm then replace/type with Keyboard Maestro
ALSO triggered by status menu
ALSO triggered by a hot key combo ieg cTL+cmD+K
and try all three in textedit

Finally if you are still stuck post a pic of your macro

Thank you, @jonathonl.

Yep, it's enabled and in "All Macros".

i've run the help and it says everything is in order.

It doesn't matter where i type those 3 letters, there is never the text pasted that i want.

Here's the screencap:
Screen Shot 2020-05-18 at May 18    6.05.22 PM

Ah, you are using a clipboard !!!
Change macro to type some text, then we can look at the clipboard issue

Part 2
a: you can see what is on the clipboard in KM Preferences (cmd+,)

b: change your macro to "paste" from clipboard to a variable e.g. temp_string
then type that variable e.g. temp_string

This will enable you to see what is temp_string (also via KM Preferences)
and then your type temp_string should work

Pesronally I prefer named clipboards whilst getting a macro to work

Named Clipboards are only useful if the data is an image, rich text, or some object.
They offer no advantage for plain text.

@Bernard-Joseph_Burch, you can never be completely sure what will be pasted from a Clipboard, the System or Named. Clipboards store a variety of flavors, and it is up to the receiving app to choose which flavor it wants.

So, I'd suggest that you use a KM Variable, instead of %PastClipboard%1%, and would probably use "Insert Text by TYPING" for short string.

Also, make sure your text cursor is in the Gmail search field when you type the KM Typed String Trigger.

i'm not completely sure what solutions are being recommended here to fix this issue. Maybe i should expand a little...

So, what i'm ultimately trying to do is clean out my Gmail that has thousands too many messages (i have about 10 accounts that all come in to my Gmail account.) To clean things up, i usually do a search in the Inbox for an email address sending me lots of email. The string i'd type/paste into the search box is this: "label:inbox @hubspot.com" That might pull up 50 emails from one account that i can delete all at once. See attached.Screen Shot 2020-05-19 at May 19    10.10.57 AM

What I want to do is find an emailer, copy their address, place my cursor in the search box and type ";li" to get it to type the filter text (label:inbox) + paste the email address that i've copied to the clipboard.

The Assistant says the shortcut is firing but when i type ";li" nothing happens. The ;li isn't deleted, the "label:inbox" isn't typed, and nothing is pasted. The ;li just sits there doing nothing. But, again, when i type ;li, KM says that it triggered. See the screenshots attached.
Screen Shot 2020-05-19 at May 19    9.44.12 AM Screen Shot 2020-05-19 at May 19    10.13.13 AM

--> NOTE that i am able to manually copy/paste the address i copied into the search field BUT when i look at the Clipboards in KM Preferences, the address isn't there. Not sure if it's supposed to be.

i should also note that i imported some keyboard shortcuts that another KM user exported and shared that included text shortcuts. This was before i tried to create my own basic one—her's are more complicated—and hers didn't work either. Same problem. Nothing happens.

Finally, i've taken the clipboard variable out of the equation and just made the macro a basic text replace. Still, when i type ;li <---- like right there...KM says it triggered but nothing happens.

It occurs to me to mention that i used to have TextExpander installed but stopped paying for it and stopped using it. It's still on my hard drive but not running. Perhaps there's a conflict? i don't want to delete it yet because there are some old macros that i'd like to put into KM if i can ever get it to work! :grimacing:

Just a quick update because i'm STILL trying to figure this out...

It seems that the bottom line is that KM won't (can't) trigger text "in line" like i'm asking it to.

It MUST be a conflict somewhere because i created a "Display text in a window" macro and it works just fine. i also added a "Speak Text" action after my "Insert Text" action and i get the speech but no text.

i've gone into my Security & Privacy settings and disabled Accessibility access for TextExpander and Alfred just in case they were conflicting. i even changed the trigger to a hot key...just for fun. It just won't paste text in place like it should.

i want to do a simple thing and it's now sucked up 2 days of my time and it's driving me crazy!

We want to help, but you need to post either the macro or a pic of the macro that is causing you problems.

https://wiki.keyboardmaestro.com/Forum on how to upload macro

Try this and see if does what you want
Assumes search field is blank.

Bonjour, @jonathonl. Thanks. i'm uploading the macro now.Gmail - search Inbox.kmmacros (1.4 KB)

This works exactly as expected...

OK This may be folklore but use type rather than paste
You can modify my example to move to search field, select all, delete and then type

Thanks again, @jonathonl. i think that's what i did: used type rather than paste.

i don't think your solution includes my original criteria of adding "label:inbox" before the address i want to search so that it only searches in the Inbox.

You also didn't upload the macro i don't think. It also looks WAY more complicated than what i think i need but if it works....:man_shrugging:t2:

But, above all, it doesn't address the issue that KM doesn't actually type the text that i'm telling it to. As i mentioned, i have other macros that i downloaded from someone that has much longer text and those don't work either. Shouldn't we address the core issue?

Thanks again. i like the program and this forum is quite useful.

Please , look at prepend text action and modify as required

Ok, i'm working on setting it up right now.

OK Goodluck
The only issue I am aware of is that KM can type too fast for the host computer, meaning dropped/repeated characters, there are number of very easy solutions to that problem.

i don't see Prepend as an Action.

Set text

The set variable to text can be modified "in situ" to
prepend, overwrote, append, so it is the set variable action you want

Click on action cogwheel to change.

After I added a Typed String Trigger, your macro works fine:


Here's a very short demo:

Sounds like you are fist punching your keyboard. It’s probably abused. Just joking... somewhat.

Anyway, Are you on Catalina by any chance??

Can you see this post and make sure you perform these steps before we go any further?