The Device Key Does Not Work

Hi everyone,

My device key does not work. I try many times. I make sure accessibility enabled for Keyboard Maestro and Keyboard Maestro Engine. Then restart. But it does not work.

Can you tell me why?

The picture above shows that I was able to use trackpad before, but now I can't use trackpad after reinstalling the system. I don't know how to fix it.

Tip: How Do I Get The Best Answer in the Shortest Time?

I found the magic mouse 2 can be forced to connect to the Mac by connecting it via a lightning cable. It then will work with Keyboard Maestro.

But if I disconnect the lightning cable, it does not work. It did work without the cable before reinstalling the system.

I don’t know why.

Is the trigger intentionally set to "Long Press"?

Keyboard Maestro aside, does the mouse function correctly when connected via Bluetooth?

Have you tried deleting the trigger and setting up a new one?

Have you tried "forgetting" the mouse as a Bluetooth device and pairing it again?

Yes, it work well. But it need to connect cable.

I updated my response above with some other questions.

Keyboard Maestro aside, the mouse function correctly when connected via Bluetooth.

I tried deleting the trigger and setting up a new one. But it can not work.

I tried remove the mouse as a Bluetooth device and pairing it again. But it can not work too.

I restart mac. It doesn't work either.

When you set up a new trigger and click the track pad, does it recognise it in the trigger box?

It is not recognized unless I connect the lightning cable

Does KM have all required permissions? Have you tried reinstalling KM?

I've done almost everything, including permissions, and reinstalling KM. I've also uninstalled potentially conflicting software, but it doesn't seem to help, and I'm wondering if there are tools or scripts to fix

It's hard for me to diagnose this issue remotely.

Perhaps @peternlewis might be able to help.

1 Like

Thank you for the same. It is no matter.

Sounds like either accessibility permissions, or the device is not a USB device, or there is a driver that holds exclusive permissions.

See: Accessibility Permission Problem assistance

Ensure you can use other keys (eg on a USB keyboard) to set Device Key triggers. That would eliminate the possibility is is an accessibility permission issue.

1 Like

My system is big sur, I gave all permissions but the magic trackpad is still not recognized.

I am using magic trackpad 2 , if connected via bluetooth, it will not be recognized, I have to connect via lightning cable to work properly. And magic keyboard works fine through bluetooth connection.

If it doesn't work, I'll just use it with a lightning cable connection for now. I use my laptop most of the time, so it's not a big deal.

The USB Device Key trigger can only detect USB Device events, not Bluetooth devices.


Ok, thanks.