Token Prompt Macro (v11.0.2)

I find myself in need of an "auto-complete" option for the tokens, so I decided to create my own. I hope this helps others with the same issue.

I got the full list of tokens by running this macro, so I believe it's updated. If not, please let me know if any token is missing.

Token Prompt.kmmacros (23 KB)

Have you tried Edit>Insert Token>By Name... ? The default shortcut is ⌃⌘T
I use this all the time.


This is that moment where I can hate you and thank you at the same time... haha
Thanks for sharing this. I wasn't aware of this :raised_hands:
I guess I needed to create this macro and share it here for someone to share that valuable piece of information :wink:


So here are the others you might be unaware of

A - insert an Action (in a macro)

T - insert a Token (in a field)

V - insert a Variable (in a field)

F - insert a Function (in a field)

W - insert an ICU Date (in a field)


I use the one for the actions all the time, but didn't know about the other ones, especially the token, which is super useful for my workflow.

The one for variables, it would be great if the list could be divided into 2 groups, where the top group would be the ones already in use in the current macro, then a divider with the list of all the other macros. But I can see how this can be useful moving forward.

Thanks for sharing.

By the way, I don't know if you know how to fix this:
I use BTT (Better Touch Tool) to assign different shortcuts to KM, because when I tried using KM itself, it was a bit inconsistent.
I can assign a different shortcut to Insert Variable/Action/Funcion by Name, but for some odd reason, it doesn't work for Insert Token by Name.
This is the BTT window:

I checked the text and it's correct. Any idea why KM isn't recognizing this?

I don't use BTT so can't help, sorry.

This seems to be an issue on KM side, because if I use the exact same shortcut in BTT to trigger Edit;Insert Action;By Name... it works. The same for variable, function, etc.
So by just changing the word Action to Token is enough to make it stop working.

I decided to go with the System Preferences > Keyboard route for this.