Unlock Trigger Is Sometimes Delayed

I use the unlock trigger to simply run a macro that verbally says "Unlocked" (see below.) Sometimes it works fine, but sometimes (usually when I unlock my screen in the morning) it doesn't run until I click the mouse somewhere on the screen. Are my expectations misplaced?

@Sleepy -

Just tested this and it worked fine (and fast) on a 2014 iMac. I’ll give it a go for the AM and I’ll report back.


Sure, thanks. I've noticed this symptom for a few weeks, but I can't say for sure if it happened every morning.

I'm on an M1 Mini. I should try it on my Intel Mini too.

So far so good @Sleepy. I'll leave this on for a few days. I'll call it until or if I have an issue but so far it has been flawless on my system.

Take care.

I understand.

This morning my results couldn't be determined, because my sound was muted on one Mini, and my screen saver was disabled on the other.

It happened to me today after returning from dinner. My screen was locked. I unlocked it with my password. I didn't hear any "unlocked" for at least ten seconds, then I clicked the mouse to refresh this KM website, and the word "Unlocked" was spoken, suggesting to me that the macro didn't run for ten seconds after the screen was unlocked.

This may not be relevant, but a few weeks ago I used to have my screen unlock automatically because I wear an Apple Watch. I don't remember this problem happening back then. Then for some reason I still don't know, I now have to unlock with a password, and I'm definitely getting this problem most of the time.

I don't think I have any third party software running in the background on my Mac. I barely have any third party software at all, besides KM and a handful of fairly harmless Apple Arcade games.

Every morning so far that I've tested, the macro still doesn't trigger until I use the mouse. This applies to both my Intel Mac Mini and my M1 Mac Mini.

Perhaps the reason you aren't getting the same result is that you are using the mouse when you unlock your system.(?)

Nope. Normally, I hit the spacebar or the escape key then my Apple Watch logs me in. Other times, I hit escape then type my password.

My machine is on Big Sur as I don’t have a machine that can rock Monterey yet. Your machine may be possessed. :japanese_ogre:

Then this unexpected behaviour is most likely caused by something in Monterey, and I should probably flag this behaviour for @peternlewis to try out.

I have a macro which will always open the notification centre after I unlock the Mac. This is useful so I can glance at the widgets (using Ventura and KM 11). I notice that the Unlock Trigger is sometimes delayed. And that some times when the Mac asked for password e.g. Accessibility password, the Unlock Trigger will trigger.

I have since turned this macro off but just wanted to flag this out in case there's a chance this can be addressed.