Yet Another "Found Image Not Working" Post... (Sigh)

I know there are other posts on here about this, and I think I've read through them and tried their suggestions. Still no joy.

This is the relevant action in the macro, in KM 9.1:

So far I've:

  • Went in and manually enabled the Screen Recording security setting in Preferences
  • Adjusted the "fuzz" a few different ways
  • Done a "Capture All Screens" action before this, just in case there was some preference in macOS that still wasn't activated (per a suggestion from Peter in another post)
  • Done a "pause for 2 seconds" before my "found image" action
  • Done a "pause until...." with a "found image" condition, using the same image and various "fuzz" settings

I'm hoping I'm missing something very, very simple. Can anybody shed some light on this?

ETA: Incidentally, this is an image in a popup (the "sharing" popup from Finder), if that matters. :slight_smile:

So...nobody has any idea?

If you gave more information (such as what’s happening before that action) it would help.

Have you looked here:

I felt this was a pretty isolated section of the macro, but if context is helpful:

KM right-clicks.
Using a pixel-based offset, it moves the mouse and clicks a menu option that brings up the "Sharing" sub-menu.
Again using a pixel-based offset, it moves the mouse and clicks the menu option for "Add People".
That brings up this popup:

That part is all rock-solid and reliable. And in fact, I've disabled everything in the macro before the step I originally posted, brought the screen up myself manually, then triggered KM with the above-mentioned action as the first action in the script - and the issue persists.

It should be moving the mouse and clicking the "Copy Link" button, but it's not.

KM has permission to record the screen, which I've seen mentioned elsewhere as a potential issue. And as mentioned above, I've adjusted the fuzzy matching slider, increased pauses, but it seems to be an issue with KM detecting the image.

KM 9.1 on Catalina 10.15.6.

Apologies for being dumb, but what is it right-clicking on?

Ah, sorry the name of a file. So it brings up a context menu.

Still being dumb here: you said “Finder” originally - is that correct because I can’t find that here!

Hey Robert,

You've gone through the steps needed to reduce transparency in Catalina?

I assume you've tried isolating this step in its own macro and experimenting without any of the preceding steps – yes?

-Chris seems the "Sharing" menu is only available in for files in iCloud Drive.

Reduce Transparency is checked in System Preferences -> Accessibility -> Display

Here's what's on my screen right now. The thing I'm trying to click is over on the left; the KM window is on the right.

For troubleshooting / isolation, I'm just asking KM to move the mouse over to the image. Just something to give me a visual clue that it's working.

With this exact screen setup, I click "Run" and I get the "Move or Click Mouse no unique image found" error. I've tried different levels of "fuzz" to try to help the match, and it doesn't seem to help.

Never test found-image actions with the Keyboard Maestro Editor visible.

The image in the editor will often interfere with the macro.

Hide the editor and use a keyboard shortcut to activate the macro.


1 Like

Just quit the editor entirely and did the hotkey - still got the same error. Tried it with a few different levels of "fuzz", same result.

Drat. I was hoping that was the problem.

Try changing the Screen attribute and change from Best to Unique.

Click in the image well and hit the spacebar to bring up quick look – inspect the image for any oddities.

Try using a bigger chunk of the window for your image – just to test.

If none of that works you'll probably need to make a formal bug report to Peter.


The action you've shown above just does a move, not a click, so I would say that not clicking is exactly what you've told KM to do. Or is there something else I'm being dumb about?

The original was a "move and click". For troubleshooting I've switched it to just "move", as that's one less step - but it doesn't do that either.

The image I'm searching for is a screenshot of the thing I'm searching for, saved as a PNG - so I'd like to hope it would be good - but I double-checked.

As for "bigger chunk", I actually had it search for the contents of the whole "Add People" popup. So that's a good-sized chunk.

Time for a bug report to Peter? Should I submit it and just link him to this thread?

Previously, users with similar issues have found that rebooting their Mac and occasionally reinstalling KM has helped - sometimes. I know, it sounds like desperation! Are you up to trying that?

Try using the Control key when you take the screenshot to copy directly into the clipboard. Then paste the image into the image well.

If that doesn't help then send Peter a detailed bug-report.

Peter Lewis <>