Cannot click at a location on screen


I am new to Keyboard Maestro, though not new to macro software.

I created my first macro, set to move the cursor to a location on screen and clicking there, triggered by F6. But I cannot get it to run, either with the function key or by pressing "Run" at the top of the editor window. I expected to see the cursor move to the location, where a finder icon lives, thus opening that file.

Other actions, like opening an application, work fine. But I want to be able to invoke a mouse click at a specific location on screen.


  1. Which macro group is your macro in and is it enabled?
  2. Is your macro enabled?
  3. Post your macro to this forum, so we can see what you're doing.

For better assistance read this Tip: How Do I Get The Best Answer in the Shortest Time?

Hi. Thanks for the reply.

I made a new group to hold the new macro. It is enabled. If I simply change the action to, say, increase the size of the front window, pressing F6 works fine. It is just the attempt to click at a location on screen that fails. This means to me that the macro setup is enabled and valid.

Oddly, the very same macro on my Powerbook works just fine. The location is where a finder icon lives, and executing the macro, which double clicks, opens that file. I can see the mouse jump to the location and, I assume, click twice.

Same version of KM (9.0.6). Same OS, Catalina.

I had used another program, KeyQuencer, for many years, but it is only 32 bit. Catalina does not support this at all. And I much prefer the interface of KM.


OK - but until you show us your macro there's nothing more I can suggest.

Screen Shot 2020-10-01 at 10.07.09 AM

The first action works fine. The second not at all.

I want to use KM mainly to automate actions in a drafting program, but also in other places. But for the drafting program, selecting tools from fixed position palettes is the reason I am trying to make the "move and click" gadget work.


Curious. I just tried it here on my Mac and it worked fine.

When you click on the Go button in the Move action, does it take your mouse pointer to where you expect? And on your Mac, what is at that screen location?

Clicking on "go" doesn't nothing.This is on an iMac 27". But it does indeed work on my Powerbook.

I am concerned, because the MAIN reason I want KM is to be able to click at various locations on screen, triggered by different mouse buttons. I wonder if there is something in my machine that is preventing this particular action from working.

Similarly to my Powerbook, I chose a location where a file sits on the desktop. That file opens, no surprise, on the Powerbook. But the cursor never travels to the specified location here.

I'm on an iMac 27". The following shows me clicking twice on the go button within KM and, sure enough, the mouse pointer jumps as expected:

Are you saying this does NOT happen with you? If you say "no it doesn't" then please provide proof because Peter Lewis (@peternlewis) will want to know about it! Oh - and here's my macro for you to look at

Test Click Go on Move Mouse Action.kmmacros (2.4 KB)

That is correct. Clicking on the "Go" button does nothing.

How do I provide "proof"?


Create a simple macro like mine that doesn't work and post it here - preferably with a video showing it not working I guess - so that @peternlewis can reproduce the bug, if that's what it is. I'm at a loss now for further suggestions for you.

Yours does not work on my machine. So I guess it is my machine. I assume that sending macros back and forth between us will reveal nothing, since mine work for you but yours do not work for me.

But I will still send whatever you ask for if you think it worthwhile

When you say my macro didn't work for you, did you change the coordinates from (3789, 783) to a place that actually exists on your system? Better still, change the action so that it looks like this:

Then when you click on the Go button, the mouse pointer will move down and to the left. Humour me.

Oh - and remember, you're not running my macro, you're just clicking on the Go button.


I understand what you are trying to do. The cursor does not budge no matter what I set in the action display.

The fact that it works fine for me on another machine makes me think that it is a local problem. Whether Stairways is still interested is another matter, but how would they proceed to find the problem without my computer in their hands.

I will try it here in my office on another iMac. Watch this space...


Good luck!

It is possible it is an accessibility issue and Keyboard Maestro cannot send the events.

You will have to ensure you enable Accessibility for both Keyboard Maestro and Keyboard Maestro Engine. If you have any troubles with accessibility (eg typing keystrokes, selecting menus, copy/paste, etc), you need to toggle the accessibility permissions (System Preferences, Security & Privacy, Privacy, Accessibility) for Keyboard Maestro and Keyboard Maestro Engine off and then on again.

The other possibility is you have some software or device that is overriding the mouse location - if you have any USB devices plugged in, remove them.


Thanks for taking an interest in this for me.

Both Keyboard Maestro and the Keyboard Maestro Engine are selected in the privacy pane. If it matters, I can toggle the engine but not Keyboard Maestro itself.

The only USB devices I have connected are a mouse and keyboard.

In "Security and Privacy" it is possible to select KM in the "Contacts" pane and the "Full Disk Access" pane, and this seems to set KM in the "Files and Folders" pane. All these are checked.

Again, on two other computers the action works just fine. There must be something in this machine that is preventing this. I installed KM "normally" on those other two, setting the accessibility checkboxes in the usual way.

Another issue. I cannot type into the field displayed when I select "Hot Key Trigger". I mentioned this earlier. I can select triggers from the pulldown just to the right of that field. This has always been the case. In the other two machines, I can type into that field without issue.

Would re-installing help?

I used to use "QuickKeys" without issue, but this is not supported under Catalina. Anyway, Maestro is much easier and more fun to use. But the most important feature for me is to be able to automate a click on a location on screen.

Apart from getting another machine, I am stumped.



Have you looked at this: Unable to Type In a Hotkey for a Macro ? It sounds like it is relevant to your situation.

Well, re-installing KM seems to have solved all my issues. I can toggle what I could not before in the accessibility pane, type into the hotKey field, whatever. I tried this before, but this time it seems to work.

Thanks to everyone for bearing with me.


1 Like