KM Bug? Export All Macros as Folder – Failed to Export

I mention the possibility of a bug mostly because there is no specific error message, no information in the engine log and the fact that a similar type of backup using @DanThomas ' macro works fine.

I am preparing backups for an off site location where I must go today. A comment by @peternlewis would be greatly appreciated.

KM 10.2 Monterey latest version.

When I try to export all macros as folder, I get the error message below. I tried multiple times.
The engine log makes to reference to that menu command

I tried to quit the KM engine and editor and restart but the problem persists.

A similar type of backup using the Dan Thomas method works perfectly.

Macro Repository Suite: Backup and Version Control for Keyboard Maestro - Macro Library - Keyboard Maestro Discourse

Am I supposed to select all macros or macro groups before running the menu command?

Thanks in advance for your time and help


Hey @ronald,

Hmm... Export All Macros as Folder... works fine for me using Keyboard Maestro 10.2 on macOS 10.14.6 Mojave.

  • Have you tried restarting the Keyboard Maestro Editor and Keyboard Maestro Engine?
  • Have you tried rebooting?

If that doesn't work I'd:

  • Select the All Macros smart macro group.
  • Select all macros contained in it.
  • Export as folder.
1 Like

thank you for your reply:

yes, many times

yes, twice

same error message

thanks again

Try selecting only a couple of macros...

Where are you trying to export to? Try a different place and give the export folder a very plain name.

1 Like

Changing the destination folder solved the problem. Thanks VERY much!!

1 Like

Glad you got things working.

What was odd about the original destination? Maybe something needs to be reported to Peter?

I changed the name of the destination and kept it short - same error message
Only works if I choose another folder, like the Downloads folder.

The @DanThomas method worked and still works.

Repeated the procedure many times.

  • In Dropbox directories the export all as folder fails 100% of times
  • In non Dropbox directories works 100 % of the time

Does this make any sense to you or @peternlewis?

So the problem is caused by Dropbox?

1 Like

it seems so, but usually Dropbox problems result in corrupted files when the Dropbox sync coincides with an file export.

I have never seen a problem where an app actually recognizes that the export folder is a Dropbox folder resulting in an error message.

Not really, but then I don't know what Dropbox is doing in its folder that might cause this.

I would guess that an attempt to create a folder, or create or write a macro file, is failing with an error message. Maybe Dropbox doesn't like some character that is used, or something about the file names.

There might be more information in the Editor.log file.

1 Like

Thank you for your post.

I tried multiple times with consequent error message. Nothing in editor log either.

as I said above:

What happens if you select one Macro Group and "Export as Folder"? What happens if you change the name of the Group to "Test Group" or similar and export that? You may also have to change macro names, so try a test Group with only a couple of (duplicated) macros in it.

Slightly worried that everything in your screenshot is named .something, which means your Groups (along with the macros inside them) will be hidden after export -- perhaps that's what's confusing things. (It doesn't on Mojave, but I don't have a Dropboxed Monterey machine to hand to test on).

No, it does not work.

Thanks for the thought.


I just ran a full export using Dropbox 165.3.4275 on macOS 10.14.6. without issue.

This suggests there's something unusual with your setup somewhere.

1 Like

thanks very much for testing ! One possible culprit eliminated

1 Like

@peternlewis @Nige_S @ccstone

I found the solution: I must pause dropbox sync for a few minutes and the export all to folder works seamlessly.

Thank you all for your suggestions.