Mojave problems

Just updated to Mojave and none of my shortcuts work.

  1. Finder shortcut to simulate some keypresses - nothing.
    Checked forum and saw that I need to specifically add applications under Automation in Sys Prefs.
    How? There seems no way to tell the system I want Keyboard Maestro to access another app.
    It seems the apps listed request access and then are granted it.
    Keyboard Maestro (KbM) is NOT requesting any access.
  2. Shortcuts within an app I had customised.
    Again these do nothing. Not asked to add to Automation. No way to do so.

I note that KbM will let me record a new macro, but when I play it still nothing. Still no request to modify System Prefs.

Should KbM be triggering this request and corresponding addition to the Automation list?

How do we proceed?

Same here. Macros don't work anymore. HELP

Fixed. Had to delete the KM entry in Security&Privacy Accessibility and then re-add. Works now

1 Like

Yes that helped.
Almost all work now except for one peculiar thing.
I have one shortcut the select and replaces text within a filename.
I place the insertion point within the name, press cmd-k and the macro selects all the text to the end (including extension) and then types ".mkv".
Only it doesn't anymore.
It types ".mv"
I fixed this (as a workaround) by getting KbM to type ".mkkv" which comes out as ".mkv"

Don't know what happens to the first "k".

Thanks for finding the other solutions.

ok, so I thought I would uncheck and recheck everything I had in the Accessibility list and got to one item that basically killed my mouse and required I restart.
Tried the macro I mentioned above and now it types ".mkkv" and so I recorrected it back to how it was.

So everything seems to be back to normal and hopefully the gremlins have all gone elsewhere.

After upgrading to Mojave, you may have to either restart or toggle the Accessibility permissions for Keyboard Maestro and Keyboard Maestro Engine off and on again.

I've restarted, toggled, deleted and readded, but I still apparently have a problem with KM. When I open the Editor and select a macro, I can't see its hot key until I click on the field, and then I see it in white letters on an orange background until I click somewhere else, and then it disappears again. I hope there's a way to get past this. Thanks.

1 Like

It's the same with "Type the [...] Keystroke" actions: blank, white on orange, blank again. I'm wondering if anyone else has reported the same or a similar problem.

1 Like

I don't think I've seen that reported, but just in case you might review this page:
Resolving Issues Due to macOS Mojave

I think your issue is pretty clear, but if you can it might help to post an animated GIF show this behavior.

I was ready to make my first animated GIF per your suggestion, but didn't immediately see how I could get a shot of the KM Editor window with the white-on-orange hot key or typed keystroke since when I type the keycode for a screenshot the field goes blank again (in addition to the key's being changed to the screenshot keycode, which I then have to change back). I may try Mojave sometime later, but for right now I'm restoring my backup disk and going back to Sierra, thanks.

The text for the hot key is drawn in the system selectedTextColor, which is normally black (or at least a dark grey of some sort), and in my tests on Mojave, it appears as a dark color when running Keyboard Maestro in light or dark mode (which doesn't really affect Keyboard Maestro since it is not dark-mode-aware).

So it seems that somehow your system has configured selectedTextColor to white. Maybe there is a preference for that somewhere in the System Preferences? I don't see anything related to it, so I don't know why you are seeing it, and I don't see any preference related to it, although you can check (and perhaps change) your General appearance preferences and see if any affect it (you probably have to relaunch Keyboard Maestro, and you may even need to restart, who knows).

Thank you, Peter. My highlight color in Sierra is Tangerine from the Crayons palette, set in General System Preferences. I remember checking on this when I was in Mojave, and the color I saw in System Preferences there was light, I think the bottom one in the list. It wasn't white, though. I'm not sure a color preference is the problem, though if selectedTextColor is normally black or dark gray as you say, and mine isn't, you may be looking in the right direction. As I wrote, I relaunched and restarted, even shut down and restarted, but nothing restored normal KM functionality to me until I succeeded in getting back to Sierra – which wasn't easy since the Mojave update reformatted my drive in such a way that SuperDuper! couldn't restore to it. I had to erase and re-reformat it back to Mac OS Extended (Journaled), and then after hours of copying, when I changed the startup disk to my restored drive and tried to boot from it, it had disappeared from the desktop and lost all of its content. So I had to spend hours restoring to it again, but fortunately this time it behaved and I could boot from it. The Mail accessory MailHub wasn't working for me in Mojave either, so this was another reason to go back. I suspect that one or a couple of other users will have my same KM issue, and that the problem will eventually be solved.

A bit off-topic, but since you mentioned this, maybe this guide will help with future macOS upgrades:
Upgrading To The Very Latest Macintosh Operating System

Thanks. In fact it was having read your message at "Should I upgrade from Sierra to High Sierra or Mojave?" on this forum that was most responsible for my jumping back down as soon as I encountered a problem. I had been consciously avoiding updating so as not to lose Network Diagnostics, which I along with others find very useful though Apple for some strange reason decided to delete it from Core Services. When I found a method at https://discussions.apple.com/thread/8098137 for restoring this utility with a new system, I lost this reason not to update, and I wanted to see if updating would enable me to copy and paste between my MacBook Pro and iPhone 6 the same way I used to be able to with my iPhone 5. This still didn't work with the new system, however, so I wound up with really no noticeable gain from the update and thus no apparent good reason to stick with it.

1 Like

I have the same problem. The workaround is to observe the title of the action, in the action plate itself.

Thanks for confirming the problem's existence. I hope you may confer with Peter so he can see exactly what's going on, if he doesn't already.

Hi Peter,

TL/DR See screenshot below.

Since Mojave, action hotkey indicators for the hotkeys I selected are blank. They work, but I can only see what is there by highlighting the hotkey pain. This is all in the editor. The title of the macro denotes the shortcut, and shortcut keys are listed in the macros column, just not on the Macros themselves.

Same with individual actions.

Please see this screenshot: https://drive.google.com/open?id=12EDe0CPeWBOxP3h5QXxFSdty_b3kkRAC

[Moderator: Here's the above image directly stored in the forum. @Ihventura_Hutch, you can easily upload any image to the forum by copy/paste, drag/drop, or use the upload button in the above toolbar. ]

Displaying Blanky.png

As I mentioned, the text is drawn using selectedTextColor which is normally black (or a dark grey anyway), and in my tests on Mojave, it appears as a dark color when running Keyboard Maestro in light or dark mode (which doesn't really affect Keyboard Maestro since it is not dark-mode-aware).

So all I can guess is some setting in your appearance has changed selectedTextColor to white. My guess would be a setting in the General system preferences, but I could not create any set of preferences that generated white text.

Alternatively, perhaps some of the Accessibility display settings might affect it. But I have no idea I'm afraid, I cannot find any way to set it or any combination of settings that results in the issue appearing on my test Mac.

I had the same issue and solved it as follows:
-Goto Settings >> Security and Privacy >> Accessibility
-Uncheck and delete KBM and KBM Engine
-Reboot machine
-Go back to those settings and add back and check KBM and KBM Engine
-Close KBM and re-open
Worked for me, good luck to you