P1 Bug: KM not opening newly updated Chrome?

It appears that Chrome just did an update. When I opened Chrome manually, I got the whats-new page.

And now my KM macro that opens a Chrome window is not working.

I tried creating a minimal macro to test the action:

It doesn't work. Nothing happens. Not with the Run or Try buttons nor with the Gear > Try Action menu option.

I tried restarted KM, both the engine and the editor. I tried shutting down and rebooting my computer.

It has the feel of some security or access permissions being messed up. Is there some place in the OS that gives KM permission to send commands to Chrome that could have gotten squashed?

It could be due to this
Enable "Allow JavaScript from Apple Events" in

That bug in Chrome 68 was 2.5 years ago. We're at Chrome 98 now. But yes, that is exactly the kind of thing that I was suggesting when I said that seemed like an OS permission thing.

This particular one was indeed already checked as allowed. Thanks.

Is anyone else having any problems?

I'm still having this problem, for two days now. It's not killer, but it's annoying.

I've restarted Chrome, KBM, and my computer several times and it's made no difference. I've been considering reinstalling Chrome, but that's a huge amount of work to reinstall all extensions, etc. Not worth it for the annoyance level.

Does anyone know the under-the-hood method by which KBM is opening Chrome? JavaScript, AppleScript, Shell? If I could try making a tiny script to do that one thing and see what errors I get, that might shed some light on the problem.

Meanwhile, I'm going to try replacing the New Google Chrome Window action with a piece of AppleScript to do the same thing and see if that keeps me going for now.

I'm not that sure what is the root cause as it is working for me in catalina using Chrome build Version 98.0.4758.80 (Official Build) (x86_64)

Perhaps you can add more information

  • OS
  • Chrome version (i know it is latest but stating it may help)
  • Try disabling all Chrome extension just to ensure it is nothing do with these.

So only "New Google Chrome Window action" does not work , browser-related actions like (Execute Javascript in browser) or other browser-related token works ?

I fixed it.

Fortunately, I had a copy of an old version of Google Chrome.app around, from version 90-0-4430. I have that because the next version of Chrome changed something and broke the ability to do cut-n-paste of tab trees in Tabs Outliner. So I let Chrome do its auto-update thing and when I need to do a cut-n-paste in Tabs Outliner, I shut down Chrome, start up the older version, do my TO reorganization, close Chrome, and then restart whatever the latest version is.

So I tried running that older version of Chrome. And when I did, I got this permissions dialog:

I said OK and then tried the problematic KBM action. It worked fine. So I closed that older Chrome and opened it again at the current version. I got that same permissions dialog again. I said OK again, and now my KBM macros, using that New Google Chrome Window action, work as expected.

After finding the above solution, I discovered there was another clue available to me, in the KM log file, ~/Library/Logs/Keyboard\ Maestro/Engine.log. There were multiple entries like this:

2022-02-08 18:50:11 Async NSAppleScript error 2022-02-08 18:50:11.117 CompileAppleScript[8548:198675] Keyboard Maestro Internal AppleScript Execute Error: Not authorized to send Apple events to Google Chrome.

So that tells me that, as I was asking above, KM uses AppleScript to tell Chrome to open a new window. I'm not sure that it would have told me how to fix it, but it would have reassured me that I was on the right track. My next step would have been to Google "Not authorized to send Apple events to Google Chrome."

I would LOVE to have a way to look at that log file directly from the KM editor.

Personally, I use a version of this macro: