Move windows between spaces not working anymore


after upgrade to Mojave the actions for moving a window between the spaces stopped working. I've tested 2 of them - first, second - both are not functional anymore for me. It appears, that the problem is somehow related to the mouse cursor or to the ability to hold the mouse cursor down.

I also tried to do it manually with holding the mouse down on a window and switching spaces with ⌃+arrow - it still works. Has anyone here some ideas or did something changed in mouse events handling in Mojave? I tried to reinstall KM and to reset accessibility permissions - it did not solved the problem.

I use this macro here from @Tom. Works fine under macOS Mojave

Bad for me - I've tested it already, it does not work. Sadly, the engine logs does not have anything meaningful:

2018-10-01 17:08:48 Execute macro “Move Frontmost Window to a Different Space” from trigger The Hot Key ⌃⌥Right Arrow is pressed

No error, nothing.

The above macro works for me on a macOS Mojave clean install and upgrade @lycopodiopsida :thinking:
You have to think the numbers after ⌥⌃ (1 - 4). ScreenFlow does not display them.

Did you check all the boxes here?

Ja, habe ich schon geprüft. =) However, I've tried to do the same with bettertouchtool, which moves windows between spaces basically with the same method - it had huge problems, working maybe one time out of 6. Then I've decoupled external mouse and bettertouchtool moves them like a champion. But: none of the KM workflows does - they just don't move the mouse cursor to the upper window part.
So, summing up - I may have some problems related to the external mouse and there is something causing miscalculations in mouse cursor coordinates. Have to go deeper, it is indeed, interesting.

P.S.: fixed the miscalculation, if moves to a selected space with ctrl+opt+1-3, but not with arrows. Almost there…

Well, this is mysterious: for some reason the mission control shortcuts for switching between the spaces are working on their own, but cannot be triggered via KM, even though the according parts of the WF are triggered… Number-based parts of the WF, switching directly to the according space, are working.

1 Like

Yes, it is a bit curious. The options to move to a specific space by simulating the Control-Digit keys works fine, but simulating the Control-Left/Right arrow does not. However you can change the Move left/right a space shortcut key to some other key (eg Command-Option-Control-Shift-O and P) and use that in your macro and that works.

No idea why the arrow keys don't work.

1 Like